Home » Sharepoint 2010RSS

"Access Denied. Verify that either the Default Content Access Account has Access to this repository,

Hi Everyone,

I know this topic has been posted numerous times before, but I have a weird one on my hands and therefore thought it reasonable to open a new thread.

I was getting this error message using the default "Local Sharepoint Sites" Content Source. I'm not sure why it started.

I had three entries, all of which point to the same SP site:

http://ecm
http://sharepoint
sps3://sharepoint

I was getting the error above for http://ecm. When removing ecm from the list, it appeared to search, but the site was removed from the search results.

I created a NEW content source of Sharepoint sites with simply http://sharepoint. I confirmed the domain account used for DCA account had Full Read on the Web app level, and wasn't a farm admin. A Farm admin domain account is used on the search services in the MMC.

This NEW content source worked! The only flaw is when I click on the site in the refinements pane, it then states there are no results. If I look at all the results, it indeed does return results for the site.

Because this source worked using the default DCA account, I'm stumped why it won't search my other mapping or by using sps3?

Any ideas would be helpful. Thanks!

 

4 Answers Found

 

Answer 1

Hve you configured AAM?
 

Answer 2

Hi ds_clark,

 

Did you add http://ecm into your alternative access  mapping? If not, please add it into your AAMs, then check the effect.

 

For more information about Alternative Access Mapping, please refer to the following articles:

 

http://blogs.msdn.com/b/enterprisesearch/archive/2010/05/28/server-name-mapping-and-alternate-access-mapping-aam.aspx

 

http://www.msdev.com/Directory/Description.aspx?eventId=1789

 

Moreover, please check if you had added DisableLoopBackCheck registry on your SharePoint 2010 server.

 

http://support.microsoft.com/kb/896861

 

Change your default  content access account  to another account, then check the effect.

 

Finally, try to create a new search  service application, then check the effect.

 

Change the default content  access account (SharePoint Server 2010)

http://technet.microsoft.com/en-us/library/cc261796.aspx

 

 

Answer 3

Hi,

I've had the same issues regarding the crawling.

I've managed to enable it with disabling the Firewall and Disable the local  loopback check running on Windows Server. Take a look at that.

To set the DisableLoopbackCheck registry key, follow these steps:

Set the DisableStrictNameChecking registry entry to 1. For more information about how to do this, click the following article number to view the article in the Microsoft Knowledge Base:
281308  (http://support.microsoft.com/kb/281308/ ) Connecting to SMB share on a Windows 2000-based computer or a Windows Server 2003-based computer may not work with an alias name
Click Start, click Run, type regedit, and then click OK. In Registry Editor, locate and then click the following registry key:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Lsa
Right-click Lsapoint  to New, and then click DWORD Value. Type DisableLoopbackCheck, and then press ENTER. Right-click DisableLoopbackCheck, and then click Modify. In the Value data box, type 1, and then click OK. Quit Registry Editor, and then restart your computer.

Regards

 

Answer 4

Hi ds_clark,

First thing with search  problems is to check several things:

1. Is AAM configered?

2. If using http, are the hostnames within IIS correct?

3. Are DNS records set corret? (Use A-records!!!)

4. Configure the DisableLoopBackCheck the right way! Do NOT follow the Microsoft kb artical on this matter because it will not work properly. Instaed follow this blog from MVP Bob Fox (http://www.spfoxhole.com/Blog/Lists/Posts/Post.aspx?ID=141). For information why you don't want to folow Microsoft's kb article on the DisableLoopBackCheck can be found from a blog from MVP & MCM Spence Harbar (http://www.harbar.net/archive/2009/07/02/disableloopbackcheck-amp-sharepoint-what-every-admin-and-developer-should-know.aspx)

5. Make sure that the path to your searchcenter is filled in correctly

If these things are correct test the search again bij doing a full  crawl.

Regards, Mark

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter