Home » Sharepoint

Access Denied/The workflow could not copy the item workflow error after Sharepoint 2010 upgrade

We have a sharepoint designer workflow that copies a document from one library to another on the same site. 

Before the upgrade to 2007 it worked fine, but now with 2010 it gives an error and cancels the workflow when it gets to the copy list item step.


The error on the workflow page:

The workflow could not copy the item. Make sure the source and destination lists have the same columns and column settings.  Access Denied


Specifically it is the "copy list item current item to documentlibrary" sharepoint designer workflow action.


I have given the system account full permissions to the library and double checked that all columns are the same in both libraries.

These are the verbose trace logs:


09/01/2010 09:46:04.05 	w3wp.exe (0x17C4)            	0x093C	SharePoint Foundation     	Workflow Infrastructure    	72er	Medium 	System.UnauthorizedAccessException: <nativehr>0x80070005</nativehr><nativestack></nativestack>Access denied.   at Microsoft.SharePoint.SPFile.UpdateInternal(Boolean migrationSemantics, Boolean reGhost)   at Microsoft.SharePoint.Workflow.SPWinOEWSSService.CommitCopyFile(Transaction txn, Object[] transData)	 
09/01/2010 09:46:04.05 	w3wp.exe (0x17C4)            	0x093C	SharePoint Foundation     	Workflow Infrastructure    	72fe	High  	Error in commiting pending workflow batch items: System.UnauthorizedAccessException: <nativehr>0x80070005</nativehr><nativestack></nativestack>Access denied.   at Microsoft.SharePoint.SPFile.UpdateInternal(Boolean migrationSemantics, Boolean reGhost)   at Microsoft.SharePoint.Workflow.SPWinOEWSSService.CommitCopyFile(Transaction txn, Object[] transData)   at Microsoft.SharePoint.Workflow.SPPendingWorkBatch.Commit(Transaction transaction, ICollection items)	 
09/01/2010 09:46:04.04 	w3wp.exe (0x17C4)            	0x093C	SharePoint Foundation     	General            	8kh7	High  	<nativehr>0x80070005</nativehr><nativestack></nativestack>Access denied.	 
09/01/2010 09:46:04.04 	w3wp.exe (0x17C4)            	0x093C	SharePoint Foundation     	General            	9mpn	High  	File exception: System.UnauthorizedAccessException: <nativehr>0x80070005</nativehr><nativestack></nativestack>Access denied.   at Microsoft.SharePoint.Library.SPRequest.UpdateFileOrFolderProperties(String bstrWebUrl, String bstrWebRelativeUrl, Object varProperties, Int32 fMigrationSemantics, Int32 fReGhost, Byte& piLevel)   at Microsoft.SharePoint.SPFile.UpdateInternal(Boolean migrationSemantics, Boolean reGhost)	 

Any help would be appreciated, thank you!

2 Answers Found


Answer 1

Does the user who started the workflow  have the privilege to copy  the file from one lib to the other ? (not the ystem account)

By default Sharepoint Designer workflows run with the current user privilege. (I haven't tested the specific case of this activity).



Answer 2

Hi jayarreye,


Thanks for your post.

I think it’s may be because that the target list id is changed.  You’d better check the workflow  file for troubleshooting. Here are the steps.

1.       Open the site using sharepoint  Designer 2010;

2.       Select “All Files” in the left navigation of  SPD, and then click “Workflows”;

3.       Find the custom workflow and open it, you will see a file, whose name is like : workflowname.xoml;

4.       Open it with the Notepad, find the “Copy list item” step in the file;

5.       You can get the ‘ToListId’ and else values from it.;

6.       Now compare it with the actual value of List ID.


More information about this:





I have created a SPD workflow that starts when a object is added to the list. The workflow edits the created item in the list, and runs fine when running as administrator. But whenever a read-only user adds a object to the list (which they can because of the list settings, List > Settings > Advanced settings > Edit access: Only their own), the workflow fails with the error message "Error updating a list item: Access denied".

With what user account is the workflow executed? Why am I getting this error?

Thanks in advance!

I'm getting this error on SP2010 RTM:

Volume Shadow Copy Service error: Unexpected error calling routine RegOpenKeyExW(-2147483646,SYSTEM\CurrentControlSet\Services\VSS\Diag,...).  hr = 0x80070005, Access is denied.

   Initializing Writer

   Writer Class Id: {35500004-0201-0000-0000-000000000000}
   Writer Name: SPSearch4 VSS Writer
   Writer Instance ID: {13687afd-3a26-4e72-a323-dda04d8c2066}



I have been racking my brain on an issue I have been having with copying list items from one list to another.  

Here is the situation:
We use sharepoint as a knowledge base for agnet support.  We have a knowledgebase list and a new article request list that use various content types. 

Content type A and B get copied to the knowledge base list, content type C gets copied into a different list.  The copy action is initiated based on if a person is in a specfic security group, then creates a copy of the item in the desired list based on the content type.

The items do copy over, but the fields using publishing HTML are missing. 

The two lists are using the same content types i.e. content type A to content type A So the fields are all the same type...

There are two additional fields in the New Article requests lists that do not exist in the list we want to copy list items too.  I don't know if that affects anything or not.

Thank you all for your help!



I have a SharePoint 2007 EE Site  (with patches up to version running on Windows Server 2008 & SQL Server 2008.
I ported an existing site from a different domain to this server by backing up/restoring the content database. The site is running fine.

I added a new sub-site and here is where I have the issue. If I create a document library, add a document, and then use the drop-down on the item to pick "edit properties" I bounce to the SP Error: Access Denied screen. My account is a site admin and has full access to the sub-site.
I can view the properties fine.

When I try to upload a document I get the access denied error message if some of the meta data properties are marked "required". The document is still uploaded. I also get the same error when I try to edit an item in a list.

I can view/edit the properties in Data sheet view fine. The libraries on the existing sites work fine. It only seems to be an issue on new sub-sites.

It almost seems like a permission problem generating the property edit forms. There is nothing in the SP log files.


 I have a sharepoint site (2007) with two subsites . while I am trying to edit  list items in subsite its giving me Access denied error even though I have the Site collection Admin Rights. 

     Please help . 


 I have a sharepoint site (2007) with two subsites . while I am trying to edit  list items in subsite its giving me Access denied error even though I have the Site collection Admin Rights. 

     Please help . 



What's the path for upgrading the SharePoint 2007 Custom State Machine/Sequential workflow to SharePoint 2010 when the current SharePoint 2007 environment is upgraded to SharePoint 2010 by an inplace upgrade?

What's the typical estimate time for upgrading SP2007 custom workflow to SP2010 custom workflow?  My gut says 40 to 80 hrs or even less than that, what’s your thoughts?

FYI...I tried to upgrade the SharePoint custom workflow built using visual studio 2008 in SP2007 environment to visual studio 2010 solution/project in SP2010 environment, I got the error messages to refer the following dll's

Microsoft.SharePoint.dll and Microsoft.SharePoint.WorkflowActions.dll

Even after referring the new dlls still the workflow design doesn't show up in the canvas...still work on this to fix mean while want to know the experts insights on this.


Vijay Gande



I created a sequential workflow in VS2010 to copy a file and its metadata from one document library to another in another site collection.  When the workflow is kicked off when item is created, the file gets copied but the metadata doesnt.  When i update the same document to kick off the workflow based on "Start this workflow when an item is changed.", the metadata now gets copied over correctly w/ no problem.  Can anyone help me w/ this issue?  Is this a bug?




Hi Folks,

 I'm uploading data from WM devices to SQL 2008 and experience intermittent errors of the type:-

 'SQL Server does not exist or access denied.' from '.Net SqlClient Data Provider' 'Procedure: ConnectionOpen (Connect()).'

 Sometimes months can occur between instances of this. I include exception handling to retry the connection - sometimes 1 retry and it connects, other times it doesn't connect at all. I've looked in the SQL Server logs and there isn't any record of the request being refused etc.

 Prior to this I used SQL Server 2000 and had the same problems - I thought this might be related to TCP / IP settings and the lack of connection pools in the Compact Framework http://support.microsoft.com/default.aspx?scid=kb%3ben-us%3b328476 but this didn't resolve.

 I put off pursuing further whilst I upgraded to SQL 2008 but the issue still occurs. Is this likely to be network connection related?

 The error is so intermittent that its very hard to put it down to one factor.

 An overview of the scenario is notice my error in:-

 Windows Mobile 6.0 device running .NET Compact Framework 3.5 and SQL Server CE 3.5 connecting to instance of SQL Server 2008 via ActiveSync 4.5.


Many Thanks,



I've seen this issue on 3 different Sharepoint 2010 implementations, including upgrades and fresh installations...

The workflow, which works fine in WSS 3.0/MOSS, operates on change of a document.  Workflow reviews a specific column and based on contents of that column, it checks out the document, copies the current item from the current library to another library in the same site and then deletes the item in the current library.

In SharePoint 2010, the following occurs.  Again, this occurs in the upgraded workflow as well as in a brand new workflow created with SPD 2010 on a site that blank / not upgraded.

Workflow starts on an item that is verified to not already be checked out. Document is checked out Document IS copied to the other library Workflow fails and is canceled with the following errors:
The workflow could not copy the item. Make sure the source and destination lists have the same columns and column settings.  (They do.)
The workflow operation failed because the action requires the document to be checked out. (The item is checked out by workflow - as is evidenced by the fact that the item is still checked out after workflow fails.) RESULT:  the copy operation does work, workflow thinks it doesn't and fails on that step, item is not deleted

I've tested this enough and on enough sites that i'm thinking this is a bug.  As such, I've tried this on a sharepoint 2010 implementation with the August 2010 cumulative update applied.  That didn't fix it.

Any help with this will be greatly appreciated. 




I just wanted to copy one list from one site to another in same site collection.

I tried following options and all came up with same Access Denied Error while trying to update it.

1. Using Import spreadsheet.

2. Saved source list as a template and create it in  target site using that template.

3. Used custom code to add those list item into the list created with same field in target site.

I got the list in target site as in source, but when i try to edit them i got Access Denied error.

if any one tried anything else to solve this issue.







SharePoint 2010 search crawl error:
The SharePoint item being crawled returned an error when requesting data from the web service. ( Error from SharePoint site: Specified argument was out of the range of valid values. )

This error is for both document and folder. The document and folder were created/uploaded via SharePoint User Interface only. Later these doc/folder were deleted. And we found the search result showing the documents that were deleted from the doc library resulting in '404 page not found error' upon clicking. Ofcourse we did an incremental crawl after  deleting the file/folder. The error is same even after full crawl.

Environment details:
1 server - WFE role
1 server - App server role
1 server - index server role

Another information if helpful: We used some third party tool to migrate few sample data in the same server but on different site collection, different content database but on the same web application. The tool migrated the data and set unique permissions too for the migrated files. We tried deleting them via SharePoint interface and that files too gave a similar error!


I've been getting the following error randomly when triggering the workflow runtime through our ASP.net web application:


      Inner Exception


      Type : System.ComponentModel.Win32Exception, System, Version=, Culture=neutral, PublicKeyToken=b77a5c561934e089

      Message : Access is denied

      Source : System

      Help link :

      NativeErrorCode : 5

      ErrorCode : -2147467259

      Data : System.Collections.ListDictionaryInternal

      TargetSite : Microsoft.Win32.SafeHandles.SafeProcessHandle OpenProcess(Int32, Int32, Boolean)

      Stack Trace :    at System.Diagnostics.ProcessManager.OpenProcess(Int32 processId, Int32 access, Boolean throwIfExited)

         at System.Diagnostics.NtProcessManager.GetModuleInfos(Int32 processId, Boolean firstModuleOnly)

         at System.Diagnostics.NtProcessManager.GetFirstModuleInfo(Int32 processId)

         at System.Diagnostics.Process.get_MainModule()

         at System.Workflow.Runtime.PerformanceCounterManager.SetInstanceName(String instanceName)

         at System.Workflow.Runtime.WorkflowRuntime.StartRuntime()

Application environment:

      Windows 2003 Server Standard Edition SP2, .Net Framework 3.5 SP1

In the dcomconfig, properties, I've the following settings:

     MSDTC tab: Use Local Coordinator -> checked, protocol -> TCP/IP

          Security Configuration: Network DTC Access -> checked, Allow remote clients unchecked, Allow remote administration -> unchecked; Transaction Manager Communication: Allow Inbound and Allow Outbound -> checked, Mutual Authentication Required -> checked; Enable Transaction Internet Protocol Transactions ->checked, Enable XA transactions -> checked, DTC logon account-> NT Authority\NetworkService

Under COM Security tab, EveryOne has Local Launch and  Local Activation permissions.

Application uses Windows authentication with identity impersonation.

With the same settings, application sometimes works and sometimes doesn't. Restarting the MSDTC process and recycling the application pool whenever this problem appears seems to help fix it temporarily. How can I fix it permanently?

Please let me know if any other details are needed.


Mohan Murali.





I created a simple workflow in SPD that is triggered whenever an item is added to a document library.  Using a custom workflow action, it looks up the creator's supervisor in AD and sends an email to the supervisor notifying them of the new document.  The document's approval status is then set to Approved.  If the supervisor cannot be found in AD, and email is sent to the creator and the approval status is set to Rejected.

When I add a new file to the document library as a "Full Control" user, the workflow kicks off, the supervisor is emailed and the document is approved fine.  But when I add a new file as a "Contributor" user, the workflow bombs with an "Access Denied" error in the workflow history.  According to the SharePoint permissions screens, "Contributor" users don't have permission to approve content.  How can I change the context under which the workflow runs in order to allow it to approve the document uploaded by a "Contributor"? 



I created a re-useable workflow in SharePoint Designer 2010, which is triggers the workflow when a list item is added and works fine. I now need to enhance it with some code and imported it into Visual Studio 2010 (Re-Useable Workflow project). I set the Target List property correctly but when I log items from the list to the history log they are all blank? Are there any other steps to take? I notice in debug it refers to $ListId - any idea where this come from?

I am trying to create a new workflow on a list item but when I save the workflow I get an error:

Error: Access Denied
Here are details in the log file:

Setting database session for {a30bbbf4-2c9f-4d23-a58e-9a0f62a5cecb}. 27532cdf-9062-4030-9e5f-7b08d6180c43
12/13/2010 15:02:00.70  w3wp.exe (0x134C)                        0x11BC SharePoint Foundation          Database                       tzku Verbose  ConnectionString: 'Data Source=pcrsql3;Initial Catalog=WSS_Content_ded96d012f474e30ac50752c495a8723;Integrated Security=True;Enlist=False;Asynchronous Processing=False;Connect Timeout=15'    ConnectionState: Closed ConnectionTimeout: 15 27532cdf-9062-4030-9e5f-7b08d6180c43
12/13/2010 15:02:00.71  w3wp.exe (0x134C)                        0x11BC SharePoint Foundation          General                        8xfr Verbose  PermissionMask check failed. asking for 0x08000000, have 0x00000000 27532cdf-9062-4030-9e5f-7b08d6180c43
12/13/2010 15:02:00.71  w3wp.exe (0x134C)                        0x11BC SharePoint Foundation          General                        8xfr Verbose  PermissionMask check failed. asking for 0x00010000, have 0x00000000 27532cdf-9062-4030-9e5f-7b08d6180c43
12/13/2010 15:02:00.71  w3wp.exe (0x134C)                        0x11BC SharePoint Foundation          General                        8e2s Medium   Unknown SPRequest error occurred. More information: 0x80070005 27532cdf-9062-4030-9e5f-7b08d6180c43
12/13/2010 15:02:00.71  w3wp.exe (0x134C)                        0x11BC SharePoint Foundation          General                        ftd0 Verbose  Access Denied. Exception: System.UnauthorizedAccessException: Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))     at Microsoft.SharePoint.Library.SPRequestInternalClass.OpenWeb(String bstrUrl, String& pbstrServerRelativeUrl, String& pbstrTitle, String& pbstrDescription, String& pbstrTitleResourceId, String& pbstrDescriptionResourceId, Guid& pguidID, String& pbstrRequestAccessEmail, UInt32& pwebVersion, Guid& pguidScopeId, UInt32& pnAuthorID, UInt32& pnLanguage, UInt32& pnLocale, UInt16& pnTimeZone, Boolean& bTime24, Int16& pnCollation, UInt32& pnCollationLCID, Int16& pnCalendarType, Int16& pnAdjustHijriDays, Int16& pnAltCalendarType, Boolean& pbShowWeeks, Int16& pnFirstWeekOfYear, UInt32& pnFirstDayOfWeek, Int16& pnWorkDays, Int16& pnWorkDayStartHour, Int16& pnWorkD... 27532cdf-9062-4030-9e5f-7b08d6180c43
12/13/2010 15:02:00.71* w3wp.exe (0x134C)

I have the following setup: Sharepoint 2010 Enterprise, Sql 2008 R2. The App pool user has db owner access to SQL content database.




I am working on a SPD Workflow that has a Collect Feedback Task and I would like to pass the values from the Current Item when users open the IP Form. Additionaly, the value is a Lookup ID so I will need to know how to set a Drop-Down List Box in the IP form so that it reflects the same selection set in the underlying Current Item.

Here's the breakdown...

List A (Document Management) has a Lookup to a value (Department) in List B

Workflow Feedback Task has a String Field for the Lookup value (Department)

IP Form has a Drop-Down List Box (Department) which is set to get Choices from an external data source (Departments)

The PROBLEM is that the IP Form always comes up with the default (blank) selection for the Drop-Down List Box, but I would like to know how to make it default to the value in the underlying Current Item's value.

Thanks for you attention!



I am having two custom lists,  First_List(Title, ID, Status) and Second_List(Title, ID)

here Status is a choice menu with values Selected and Rejected

I am copying data from First_List to Second_List using WorkFlow with SharePoint Designer, When I am inserting data in first list.

For that I have written in workflow action

if CurrentIten. Status equals Selected 

Copy item in current item to Second List

now the Problem is that only the Title field is getting copied into the Second List but

I am unable to copy the ID field.

I am unable to understand whats the problem




I want to create a workflow where:

When a document is modified, it is copied to a new folder.

I can do this with the "copy list item" action, but it only allows me to select certain lists (document libraries for example), instead of being able to give a full pathname to a folder.  What's the correct action to copy the Current Item to specific folder within the same library.  Or alternately, to create a list that IS the correct folder.




In our production environment when selecting "Copy & Modify" on a Globally Reusable Workflow in SharePoint Designer the workflow doesn't copy yet there is no error message displayed.  I have the appropriate permissions and even used the SP admin account to no avail.  What is even more unusual is that some of the Globally Reusable Workflows are not available when you try to create a workflow on an existing list.

However this will work on a test environment.


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure