Home » Windows OS

Code 642 for Windows Update

Windows Aupdates encountered an unknown error (code 643)

I need HELP.!!!!!!!!!!!!!


1 Answer Found


Answer 1

Try the Windows Update forums on Microsoft Answers

This forum is for help in writing software.




Does The 70-642 ,70-647 And 70-649 Have an Simulation Questions

Or It Just An Multiple Choices Questions ?


I'm preparing to take my first Microsoft certification next month, 70-642  (and eventually go up to MCITP: Server Administrator in the future)

For anyone who has taken this exam... what can I expect? For example.. is it all multiple choice?  Or are their lab simulations as well?

I'm preparing by following the Microsoft "Self Paced Training Kit 70-642" book, any feedback on this book? Is it lacking in any area?



Received update to install .net framework 4 in October.  It will not install and errors each time it tries to update.  Error message states it is not for my platform.  I am running Vista 64 bit. 

Please see attached error copied below from Windows Update. 

How do I fix this?

Security Update for .NET Framework 4 on Windows XP, Windows Server 2003, Windows Vista, Windows 7, Windows Server 2008, Windows Server 2008 R2 for x64-based Systems (KB2160841)

Installation date: ‎12/‎6/‎2010 11:39 AM

Installation status: Failed

Error details: Code 66A

Update type: Important

A security issue has been identified that could allow an attacker to compromise your Windows-based system that is running the Microsoft .NET Framework and gain complete control over it. You can help protect your computer by installing this update from Microsoft. After you install this item, you may have to restart your computer.






trying to installed windows updates for service back .net 1.1 on Vista Ultimate and keep getting error code 643.   tried everything i could find (adobe fix, windows installer etc..) and nothing.  anybody got anything new?


We're testing our software for Windows 2008 compatibility and I'm coming across an issue with accessing sockets on a remote component.


We have a Windows service that listens on a port for a connection from another program. It works fine under Win2k / Win2003, but not on Windows 2008.

Initially, the output log for the service showed the following error when the conenction was attempted

"System.Net.Sockets.SocketException: An address incompatible with the requested protocol was used"

A check on Google showed that this was likely down to the fact that Win2008 uses IPv6 as default, and so I needed to change the service to accept the correct address family, so the service code changed from:


byte[] bytes = new Byte[1024];

// Establish the local endpoint for the socket.

IPHostEntry ipHostInfo = Dns.GetHostEntry(Dns.GetHostName());

IPAddress ipAddress = ipHostInfo.AddressList[0]; IPEndPoint localEndPoint = new IPEndPoint(ipAddress, listenPort);

// Create a TCP/IP socket.

Socket listener = new Socket(AddressFamily.InterNetwork,

SocketType.Stream, ProtocolType.Tcp);

// Bind the socket to the local endpoint and listen for incoming connections.









byte[] bytes = new Byte[1024];

// Establish the local endpoint for the socket.

IPHostEntry ipHostInfo = Dns.GetHostEntry(Dns.GetHostName());

IPAddress ipAddress = ipHostInfo.AddressList[0]; IPEndPoint localEndPoint = new IPEndPoint(ipAddress, listenPort);

// Create a TCP/IP socket.

Socket listener = new Socket(ipAddress.AddressFamily, SocketType.Stream, ProtocolType.Tcp);

// Bind the socket to the local endpoint and listen for incoming connections.






(the only change being the first parameter in the Socket constructor)

I now no longer get the exception, but when the other program tries to communicate with the service, it returns with an error indicating "The socket has been shut down".

The connection attempt doesn't even show in the event log for the Windows service, although trying to connect via telnet will allow me to send one character before shutting down, and that does show in the log.

Is there a problem in the Windows service code above (is more code needed to determine that?), or could there be a Windows configuration setting I need to change?


Thanks in advance,


Have tried 5 times to download and install this update and it fails. Have tried downloading and installing Service Pack 2 and it fails. Have tried downloading and installing the Vista Update Readiness toll and it fails. What is going on and has Microsoft issued fixes for these problems?

Newbie so sorry for the dumb question but I'm having a real problem with this simple little issue for some reason.  I have a label and text block on a WPF window and I'm trying to update those from a 2nd cs code file. I've tried the below code but the label is not getting updated...any help is greatly appreciated!  

MainWindow main = new Main MainWindow( );

                 main.statusLabel .Content = "Blah...blah";

                 main.statusTextBlock .Text = "Blah...blah";


Hi my name is Matt, I'm sitting the 70-642 exam soon, Im pretty nervous yet confident, has anyone got any advice they could give me, previous exam experience? This is my first Microsoft based exam I have ever sitted. so I'm hopeing for it to go well. 

Any input will be most appriciated :),







We have a handful of .NET 3.5 apps that we are trying to recompile with an updated code signing certificate since the old certificate has expired.  Some of the assemblies are strong named signed but they are all Authenticode signed (including the setup.exe and MSI).  The problem is when we try to install over the older/existing install using the updated windows installer the installer says that it completes successfully but when we look at the installation folder it appears the installer has failed or performed a partial rollback.  Some of the application's primary and dependent assemblies are missing.  Clicking the applications shortcut on the start menu appears to perform the windows installer "auto repair" and the application then appears to function properly. 


Here are some general statements that may help suggest a resolution:


1. The applications were originally developed and built using VS 2008.  Now we are using VS2010.

2. We have tried this on 2 different applications/solutions and they exhibit the same problems (both 32-bit and 64-bit).

3. VS 2010 Deployment Project Properties:  DetectNewerInstalledVersion is true, RemovePreviousVersions is true, we incremented the installers version which updates the ProductCode guid, the .NET Framework launch condition is .NET 3.5.

4. Our current development platform is a fully updated Windows 7 Ultimate 64-bit workstation with VS 2010 Professional.


Here are some things we have tried:


1. Enabled msiexec logging "/L*v install.log".  There are no blatant errors that we can see.

2. Tried using Orcas to see if it would tell us anything.  We aren't really sure what to look for.

3. Used Sysinternal's process monitor to see if it would tell us anything.  Even after filtering the logs to view just the msiexec.exe and setup.exe and only registry and file entries there were still 30,000+ entries to look through.

4. We tried creating a completely new test solution with a simple WPF app and a corresponding setup but can't seem to reproduce the problem.  Of course we can't sign any of the assemblies with the expired certificate so it may not be a fair test.

5. We have tried installing one of the applications in a fresh Windows XP VPC and then tried to update it with the newly built install and the same problems occur.

6. We have tried changing some of the VS 2010 Deployment Project Properties like RemovePreviousVersions to false which seems to get everything installed an working properly but ultimately that leaves old copies of the previous Windows Installer files laying around which we would like to avoid if possible.





1.       I know there are problems with ClickOnce Deployment and expired certificates.  Could something similar be happening here?

2.       We never had this problem in VS 2008.  We have updated the apps in this same fashion many times granted we haven’t change certificates.  Is this a VS 2010 problem maybe?

3.       What other ways are there to troubleshoot MSI installs?



We really appreciate your time in helping us with this matter.  Any suggestions are greatly appreciated.


I've installed release Standard 7 toolkit, and WEDU from MSDN.

I'm not seeing the updates I expected to see associated with the recent batch of updates released for Standard 7.

I've specified "C:\Program Files\Windows Embedded Standard 7\DS" as the distribution share to update (it's not rejected by WEDU as a distribution share in any case) - but when checked for updates, that gives a "Search Failed. HResult: 0x8024402F" on the search activity window.

I'm inside a corporate-managed WSUS environment - should this matter or make a difference?

Will our IS people need to add any new servers or environment to the corporate firewalls to make this work?




I am having this problem on a windows server 2003 standard edition. The .NET 2 SP 2 update fails and the other two claim to install successfully but they show up on the windows update all the time.

Others are having a similar problem in various forums in the Internet but I have not found a real solution for this yet. Any help is much appreciated.


Microsoft .NET Framework 3.5 SP1 and .NET Framework 2.0 SP2 Security Update for Windows 2000, Windows Server 2003, and Windows XP x86 (KB979909)
Download size: 0 KB , 0 minutes  (Downloaded; ready to install) 
A security issue has been identified that could allow an attacker to tamper with digitally signed content without being detected, when this content is being consumed by an application that makes use of the Microsoft .NET Framework on a Windows-based system. You can help protect your computer by installing this update from Microsoft. After you install this item, you may have to restart your computer.  Details...
Don't show this update again
Microsoft .NET Framework 3.5 SP1 Update for Windows Server 2003 and Windows XP x86 (KB982168)
Download size: 0 KB , 0 minutes  (Downloaded; ready to install) 
Install this update to help strengthen authentication credentials in specific scenarios. After you install this item, you may have to restart your computer.  Details...
Don't show this update again
Microsoft .NET Framework 2.0 Service Pack 2 Security Update for Windows 2000, Windows Server 2003, and Windows XP (KB974417)




Trying to update VS2008 on Windows 7.  Windows Update hangs halfway through installing KB972221.  Exit and restart WU returns to the hang.  No way to kill it, no way around it.

I am running Windows 7 Professional on a 64 bit platform and have Windows update on and selected to notify me when updates are available.  The other day, I received an error message that an update failed to install properly.  The update that failed is to update SQL Server 2008 SP2 - KB 2285068.  I have made several attempts to retry this update with the same result.  When I Googled the error message, all of the responses deal with the SQL Server 2008 SP1 update not SP2.  Couldn't find a solution to this problem - nor could I find one in the KB article - which basically explains details of SP2 and DOES give me the option to instal SP2 from here.  Don't want to take the chance and download it from here - maybe I should though.  Can usually find a solution to a Windows update error in Google - can't find one this time.

Any suggestions?

Jim Cutrara



I hope is the right forum... I have just installed the VS2010 release (trial) and encounter a weird situation -

This code (from MSDN Documentation http://msdn.microsoft.com/en-us/library/0c899ak8.aspx ):




value AsDouble

value = 123







works like it should but when while in run time, I'm trying to run the following code in the Immediate Window:



I'm getting the following error:


{"Enum value was out of legal range."}

_HResult: -2146233086

_message: "Enum value was out of legal range."

ActualValue: Nothing

Data: {System.Collections.ListDictionaryInternal}

HelpLink: Nothing

HResult: -2146233086

InnerException: Nothing

IsTransient: False

Message: "Enum value was out of legal range."

ParamName: Nothing

Source: Nothing

StackTrace: Nothing

TargetSite: Nothing



Any idea what is going on?



I have some code to display balloons and for send information to internet, everytime i use Visual Fox i enter as administrator and also have register cdosys.dll  but since i install internet explorer 9 nothing works

to display balloons appears a windows message  with "Ole error code 0x80040154 unknown com status code"

Does internet explorer 9 have something to do with those rutines?


Hi @all,

i'm not sure whether this is the right forum for my question but i hope you could help me.

I tried to install Windows Server AppFabric on my W2K8 R2 EN x64 Standard Ed. which is a domain member server but it fails with this error showing up in the System Windows Log:

"Installation Failure: Windows failed to install the following update with error 0x8e5e03fa: Update for Windows (KB970622)." I did everything what is described in MSDN Library in "Installing Windows Server AppFabric" section. All described features are installed. The file i use is WindowsServerAppFabricSetup_x64_6.1 which should be correct for my environment.
It doesn't matter which features i choose in the installation wizard I always get the same error. The wizards checks the required windows components and says they are fine. Then the wizard tries to install the first feature "Hosting Services" and aborts. The detailed reports says: "Failed call to CryptCATAdminAddCatalog. [HRESULT = 0x8e5e03fa - JET_errReadVerifyFailure]". The hex result corresponds to the error value shown in system windows log.

My windows update service is up and running.

Any ideas?

Thank you in advance.




Sorry, but I can't seem to find this information anywhere... Imagine that i submit a game for Windows Phone 7 to the Windows Marketplace, some customers buy it and install it. Later, i find that the game needs some kind of update/patch because of an undiscovered and infrequent bug. Will there be any option to send a new version of the game to the Marketplace so the customers that already bought the game can update it with no further charges to them? Or is there some other solution for these kind of issues?

Thanks and best regards.

Is windows phone 7 the updates of windows mobile 6.5, and what're the features in Windows Phone 7.


I have working on windows 2008 server oprating system. When i run  windows update  i am getting error (code is 0x80070005) 
below is the windowslog file  plz fix my problem.

2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {4D82F42A-DB59-4770-A340-EA7565374C86}.100 to search result
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {9A0F532B-0E4F-4E3A-AE1E-BF74AD228214}.100 to search result
2010-08-03 09:15:59:829 1044 794 AU Setting AU scheduled install time to 2010-08-03 21:30:00
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {9D0DF42B-C207-4339-B94F-D992EF1ABA37}.101 to search result
2010-08-03 09:15:59:829 1044 794 AU Auto-approving update for download, updateId = {60B6CC5E-65F6-4BD7-8149-7AA5CD965729}.101, ForUx=0, IsOwnerUx=0, HasDeadline=0, IsMinor=0
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {81F85A2C-8E9F-4FF8-B9CE-EA75E26D79C5}.103 to search result
2010-08-03 09:15:59:829 1044 794 AU Auto-approving update for download, updateId = {CD49FD68-8951-4CAE-BA1C-FBCA50664A90}.100, 08-03 09:15:59:829 1044 1404 Agent   * Added update {9E4B852F-83D6-4170-8CE6-060093643E34}.101 to search result
2010-08-ForUx=0, IsOwnerUx=0, HasDeadline=0, IsMinor=0
2010-03 09:15:59:829 1044 794 AU Auto-approving update for download, updateId = {E4CFCAAA-8C7F-4182-9907-900BEE467014}.100, ForUx=0, IsOwnerUx=0, HasDeadline=0, IsMinor=0
2010-08-03 09:15:59:829 1044 794 AU Auto-approved 3 update(s) for download (NOT for Ux)
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {29C00236-8925-4A0B-889F-5712F428B10B}.101 to search result
2010-08-03 09:15:59:829 1044 794 AU WARNING: ISusInternal::CanInstallNow failed, error = 0x80070005
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {A9A9123C-83B6-4A9E-B2B9-31B69A9B095A}.103 to search result
2010-08-03 09:15:59:829 1044 794 AU #############
2010-08-03 09:15:59:829 1044 794 AU ## START ##  AU: Download updates
2010-08-03 09:15:59:829 1044 794 AU #########
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {96702740-2DBB-45F8-B654-2CFA2B65DB12}.101 to search result
2010-08-03 09:15:59:829 1044 794 AU   # Approved updates = 3
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {7066A142-ACD5-4777-82EC-14AFFAD49713}.101 to search result
2010-08-03 09:15:59:829 1044 794 Agent WARNING: WU client fails CClientCallRecorder::BeginDownloadUpdates2 from AutomaticUpdates with error 0x80070005
2010-08-03 09:15:59:829 1044 794 AU WARNING: BeginDownloadUpdates failed, error = 0x80070005
2010-08-03 09:15:59:829 1044 794 AU WARNING: CreateDownloadCall failed, error = 0x80070005
2010-08-03 09:15:59:829 1044 794 Agent WARNING: WU client fails CClientCallRecorder::BeginDownloadUpdates2 from AutomaticUpdates with error 0x80070005
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {07609D43-D518-4E77-856E-D1B316D1B8A8}.102 to search result
2010-08-03 09:15:59:829 1044 794 AU WARNING: BeginDownloadUpdates failed, error = 0x80070005
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {9BCC5C47-545B-42B5-8F24-98866F39F9F0}.103 to search result
2010-08-03 09:15:59:829 1044 794 AU WARNING: CreateDownloadCall failed, error = 0x80070005
2010-08-03 09:15:59:829 1044 794 Agent WARNING: WU client fails CClientCallRecorder::BeginDownloadUpdates2 from AutomaticUpdates with error 0x80070005
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {A3F6695A-07CD-4794-B2FD-AB7005991F50}.101 to search result
2010-08-03 09:15:59:829 1044 794 AU WARNING: BeginDownloadUpdates failed, error = 0x80070005
2010-08-03 09:15:59:829 1044 794 AU WARNING: CreateDownloadCall failed, error = 0x80070005
2010-08-03 09:15:59:829 1044 794 AU   # Pending download calls = 0
2010-08-03 09:15:59:829 1044 1404 Agent   * Added update {8E95315D-4A24-40A9-ABA5-EC2793D784B7}.100 to search result
2010-08-03 09:15:59:829 1044 794 AU   # WARNING: Exit code = 0x80070005




I have a desktop app that installs windows updates using the Windows Update Agent, problem I have is that it works on XP machines but when I run on a windows 7 machine I get this error

"Exception from HRESULT: 0x80240044


   at WUApiLib.UpdateDownloaderClass.Download()
   at CheckSystemUpTime.Form1.btnInstallUpdates_Click(Object sender, EventArgs e)

WUApiLib.IDownloadResult Download()"


Here is my complete code for running the updates

//Install Updates
          UpdateSessionClass uSession = new UpdateSessionClass();
          IUpdateSearcher uSearcher = uSession.CreateUpdateSearcher();

          ISearchResult uResult = uSearcher.Search("IsAssigned=1 and IsInstalled=0");
          UpdateDownloader downloader = uSession.CreateUpdateDownloader();
          downloader.Updates = uResult.Updates;

          UpdateCollection updatesToInstall = new UpdateCollection();
          foreach (IUpdate update in uResult.Updates)
            if (update.IsDownloaded)

          IUpdateInstaller installer = uSession.CreateUpdateInstaller();
          installer.Updates = updatesToInstall;

          IInstallationResult installationRes = installer.Install();



<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure