Home » Microsoft Technologies

Display Project Detail Pages on the Project site

Can anyone tell me if it is possible to show either the Project Detail Pages or the Enterprise Custom Fields that they are comprised from on the Project site that is created after the workflow has started. It seems like it should be possible but I haven't found a way to do this.




2 Answers Found


Answer 1

Hi Gary,

There is a solution starter at http://code.msdn.microsoft.com/P2010SolutionStarter that includes a component that allows Enterprise Custom fields  to be displayed on the project  site called Workspace Project Custom Field Web Part .  That might meet your requirements.

hope this helps.


Answer 2

Hey Alex,

That is exactly what I was looking for - thanks  so much for that. I also found  the Dynamic workflow  to be another little gem that is also exactly what I need for our workflow needs - that Solution Starter download has a bunch of good things in it.

Thanks again for the pointer.





When any of the Team members or Project Managers try to add any attachments (Risks, Issues or Documents) using the Task details page, the document gets uploaded, can be seen in the Project Documents library, downloaded etc. However, none of these show up in Task details itself. I tried activating versioning, and requesting approvement for each document, and the process goes as expected, however nothing happens. No associated errors are shown in the Event viewer.

I recall that we had the same problem using Project server 2007, and I've googled out that we're not the only ones with it.

Am I missing something?


In the Solution Starters there is a Web Part for displaying project custom fields on the project site. This implies that per default one should be able to display standard fields (like the SV, CV etc. fields) on the site. Anyone know how to do that on 2010?

There is probably an easy answer to this, but I have not been able find any clear description.

PS! There is a web part that displays the project details (per task), but cannot find one that shows the summary.

Thx, Stig


Hi all, 

I have two tables:  Book and author and they have one to many relation.One book may have more than one authors. Book table has Title column and Author table has AuthorName Column.

I have search page contains two textboxes: Title Textbox and AuthorName textbox to search the record.


When the user type something and hit the search button it display the Title when click the title ; it redirect to detailsPage.aspx Passing value ID.

<asp:Repeater ID="Repeater1" runat="server">   
                        <table cellpadding="5" cellspacing="2">   
                            <tr bgcolor="Gray">   
                                    <b>Lists of your Search</b>   
                                <asp:Label ID="RecordN" runat="server" Font-Bold="true" Text="Record Number:" ForeColor="black"></asp:Label>   
                                <%# DataBinder.Eval(Container.DataItem, "ItemID")%><br />   
                                <asp:Label ID="Label1" runat="server" Font-Bold="true" Text="Author(s):" ForeColor="black"></asp:Label>   
                             <asp:Label ID="Label2" runat="server" Font-Bold="true" Text="Title :" ForeColor="black"></asp:Label>                                  
                                <asp:HyperLink ID="HyperLink1" runat="server" NavigateUrl='<%#DataBinder.Eval(Container.DataItem,"ID","DetailsPage.aspx?ID={0}" ) %>'>   
                                <%# DataBinder.Eval(Container.DataItem,"itemTitle")%></asp:HyperLink><br />   

Then in the Details page there are: Title, authors and other more from these table column.

My problem is:

When the user search and hit the search button, it display the number of matches Title only. I want to display authors related to this title in this page and other are same(when click the title go to detailspage.aspx) 

How can I display the related Authors to each title in search display page (Not in details page, I know in details page) ?


If user search "The Letters and life" in the Title textbox and hit enter data should looks like:

1. Author: Payne Paddy, sed ran, der virma and Caroline Barron.
    Title:The Letters and Life of Elizabeth Despenser, Lady Zouche (d. 1408) [her letters and will provide a glimpse of her personal

2.  Author: ayne manu, edd saan and fer wertu.
    Title:The Letters and Life of Elizabeth


Any help is highly Appreciated.



I have a SP 2010 Designer approval workflow attached to a SharePoint list (called request list). So once the wofklow kicks off it creates the task form in task list. The default sharepoint task page shows only the task list fields and not the original request fields, for viewing the request details the user has to navigate to another page.

Is there any way possible to show the original request item details in the task form page?


This is a really minor, annoying problem, but if anyone has an easy answer, I'd love to know it.

I'm pretty much a newbie and have been using Visual Web Developer for about a year.  I've switched to using VWD 2010 Express this year when I upgraded to Windows 7.  Almost all of the websites that I've created show up on the Start Page in the Recent Projects section -- except for one!  I can go to "Open Web Site" and find it, but it never appears in the Recent Projects.  This is one that I'd love to put a pushpin in (one of my favorite features!), but I can't figure out why it won't show up. 


Any ideas?

Our Company is currently using Sharepoint 2007 as our intranet.  We want users to start using it for more collaboration and search funtionality.  One function we would want to give each user is the ability to modify their extension number.  However, users cannot edit  the "Work Phone" field in the My Site.  Is there a way to be able to modify this field?
In MSPS 2007 the web part was called Project Workspaces and was defaulted to appearing on the home page.  Is there a webpart that will do the same thing for MSPS 2010?
I have imported a project from Project Pro 2010 following the instructions in your Implement and administering PP2010.  When I go to the Project Center, click on the project, I get a screen that says no Project Detail Page is found.  I did complete the Project Detail Page.  This has happened 2 times...



I have a question in regards a PDP that I want to create.  What type of web part category/ web parts (if applicable) should be using to in Project Server 2010?  I would like design a page where we can capture certain information in a about a dozen or so fields.  These fields are not project fields (e.g., they simple comments, etc.), and we don't need them to be project fields.  They are just some basic pieces information that we would like to capture and display.  We do not need to search on these fields either.  It is just a simple PDP page with some basic info that we want to establish and display.  Is there an applicable Web Category/ Web Part I can do this with?  or do I have to create a project field and use the Project Field web part?  I hope it is not the latter.

Thanks in advamce,

/Spiro Theopoulos



I've created several Project Detail Pages showing several fields in a development environment. Now I want to deploy those PDPs to a staging and later to the production environment. How to achive this?

I can download the PDPs from the document library on my development environment and upload them to the PDP doc lib on the staging environment, but however when I open a PDP it is empty, which means it doesn't contain the Project Server Project Fields web part.

With kind regards,



I want to create a web page for order entry using ASP.NET MVC- Entity Framework. This page contains Order and Order Entry information. For each Order, I can have multiple Order details. If you know how to do this Master/Detail with ASP.NET MVC-Entity Framework please let me know. The user should be able to enter new order with one or many order detail. this should be on one single page.


I have a ClickOnce application I am publishing to a web site.  The Publish page is set to automatically increment the revision number on each publish.  I've just published.  The current number is and I can see that the newest folder on the server is called <program_name>_1_0_0_115.  The newest manifest file is called <program_name>_1_0_0_115.application

Everything appears to be working fine as far as installation is concerned.  The users appear to be getting the latest software. 

The only problem, if it is a problem, is that when the install page is called up, it says:




I am using SP2010.

I have a custom list which is "Homepage Images".
It has two fields Title(text) and Image(that holds the Url of the image[For e.g., <img alt="" src="http://qdcsp:32463/sites/ABCWCM/SiteCollectionImages/PR.gif" style="BORDER: 0px solid; ">

I want to display the image on my page(Homepage). How do I do it?




I just recently upgraded a site from 3.5 to 4.0.  After editing the web.config, creating a new app Pool in IIS, configuring the site to use 4.0 and the new app Pool, I can no longer browse to any default.aspx page without explicitly typing 'default.aspx'. This site was originally written for .NET 2.0, upgraded to 3.5, and finally updated to 4.0 a few days ago.

If I try to browse to http://[mysite]/ I see the following error:

Server Error in '/[mysite]' Application.

The resource cannot be found. Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

Requested URL: /

Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.0.30319.1

However if I browse to http://mysite/default.aspx, everything works fine. 

If I undo all the changes made to the web.config, and revert the site back to the app Pool used for 2.0/3.5 the site loads and runs fine.  Restarting IIS will solve the problem for an hour to a day, but the issue will always come back. 

Other sites running on our sever which were not originally made in 2.0, but 3.5, have upgraded to 4.0 without this issue.  Any assistance would be great appreciated.


I'm using Windows Vista SP2 and trying to learn Sharepoint 2010. I'm new to Sharepoint and I'm sorry if I'm asking something very simple.

I've successfully installed Sharepoint foundation 2010 and VS 2010. According to the installation instruction if the installation is successful I should see the new sharepoint website home page or ask for login info which will take to the home page. But for me it displayed a blank web page. I was able to get to Sharepoint Central administration page by clicking the browse option from IIS, it asked me login info and when I provided that I was able to see the Sharepoint central administration page. Now I am trying to create a new site collection, it is succesfully creating the new site collection and showing the link, but when I access the link I see a blank webpage. I think it is some permission issue and if the program prompts login, it should work, but how can I get to the login window or how can I see the home page and not a blank page?



I am using sharepoint 2007 sp2, it has been workig fine for the past 8 months but since one of the developers installed .net 4.0 framework, every time we create a new sharepoit publishng site or extend and existing application the home url displays an "Unknown File Type" security warning message and asks users to download the file.  If i manually tupe in the full url http://www.mysite.com/pages/default.aspx it is displayed correctly. I have uninstalled .net 4 from the server but i still have the same  error. I have tried to replicate this error on a development server but sharepoitn works fine on that even with .net 4.0 installed.

Has anyone had the same issue ? I would appreciate  any suggestios or help with troubleshootig this issue.


We have created a new Site to store Knowledgebase Articles. The articles are being added as items in the list. We now want to find which are the most viewed items. When I look at Site Analytics, I find several pages being returned including what I believe are the Items viewed. When I look at the details under the graph or when exported to Excel, this the is extent of the Page URL (/lists/kbarticles/dispform.aspx?...). There are several occurances of this same URl which I expect are separate items that have been viewed. How do I get the ID of the item or other information, so I can track it to the specific Knowledgebase Article? Additional information: I can click on the URl and it will take me to the unique Knowledgebase Article. 


I have just spent the afternoon customising my "project site template 01" (.../PWA/projectsitetemplate01/default.aspx).  And I think I am nearly there.

To test the changes, I created a new project to generate a new Project Site.  I had some problems generating the Project Site, and had to enter the site name using Server Settings > Project Sites.  (Thank-you Matt Rowe at http://social.technet.microsoft.com/Forums/en-US/projectserver2010general/thread/9e919ad0-0e0e-4442-b6e2-2419dffb3544 .)

To my consternation, the generated site looked like the pre-customisation site.

Thinking maybe Test 5 had been used before (and be showing me an old site), I returned to Server Settings > Project Sites, deleted the site, and created a new one.  And it is still showing as the pre-customisation site.

Then I checked Server Settings > Project Site Provisioning Settings, and I am definitely pointing to projectsitetemplate01.

Then I closed everything (with fingers crossed), and re-opened it all to find that projectsitetemplate01 has all of the customisations still showing.

Browsing in Site Settings I found "Save site as template", and did so, saving it as projectsitetemplate02.  Then I went back to Server Settings > Project Site Provisioning Settings, and I pointed PWA at projectsitetemplate02.

Then I created a new test project, to find that the Project Site was created without the customisations again.

I would appreciate any assistance I can get on this one.  (I am hoping I am 'this close' to resolving my previous issue - http://social.technet.microsoft.com/Forums/en-US/project2010custprog/thread/c15087c0-72ed-42db-a9b5-19019525e2ff - if I can just test it out.)

Thanks in anticipation,    ...Geoff 


We have a number of Team sites / sub-sites and document libraries contained within them.

I want to collate a few of these document libraries as a single list and display on a page within a Publishing site.

Using a linked source I've been able to do this within a Team site, but am unable to successfully render the list on the Publishing site.

I'm using Sharepoint 2010, and would appreciate any hints / tips.




Is it possible to build a specific Web page which will display all the Enterprise project templates?



<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure