Home » C++ Programming

explain this error "WERC30D.tmp.WERInternalMetadata.xml"

Can you tell me if this is a memory error, cpu, or anything specific?

i'm complied a program in windows 7 and using vc++ 2008 with sp1 and windows sdk 7 and no error found. This program is running properly. The program hook keyboard and mouse properly.

i don't know, how to came this problem. 



Files that help describe the problem:





Read our privacy statement online:



If the online privacy statement is not available, please read our privacy statement offline:




1 Answer Found


Answer 1

Jigyanshu wrote:
>Can you tell me if this is a memory  error, cpu, or anything specific?
>i'm complied a program  in windows  7 and using vc++ 2008 with sp1 and
>windows sdk 7 and no error  found. This program is running properly.
>The program hook keyboard and mouse properly.
No, we can't tell you anything about this. Those files are just temporary
files that contain information about the problem, just in case you wanted
to send the bug report to Microsoft.
You need to run your application under a debugger to figure out what is
causing the problem. Alternatively:
> C:\Users\Jigs\AppData\Local\Temp\WERE1B3.tmp.mdmp
That file contains a memory dump that you can load into Windbg to get an
Tim Roberts, timr@probo.com
Providenza & Boekelheide, Inc.


hai .........

I am working with VS 2005  Team suite.  developing in a C# Windows Application.

last day i changed the icon of the .exe (  Default Icon to  my.ico file.) . then build the application

but i get a error    

'C:\Documents and Settings\Administrator\My Documents\Visual Studio 2005\Projects\WindowsApplication2\WindowsApplication2\obj\Debug\CSC28.tmp' is not a valid Win32 resource file    

please help......



I am passing a X12 document as a string to a webservice which execute EDIReceive pieline.

Whenever i have a "&" followed by space in any segment of the data in X12 ,the receive

pipeline fails and gives the below error.If remove the space after & then the x12 passes thru

the pipeline.I checked the xml when the port fails and the xml is only upto the & and further

parsing is not done by the EDI engine.Any ideas why we should not have a space after & which

is considering it as a transaction terminator.




Error encountered during parsing. The X12 transaction set with id '' contained in functional group with id '20', in interchange with id '', with sender id ' ', receiver id '990040115      ' is being suspended with following errors:

Error: 1 (Segment level error)
    Position in TS: 8
    7: Segment Not In Proper Sequence


Hi ,

         I am using fck editor in asp.net and c# .It works well on my localhost but it gives error on live server when i upload an image through fck,The error is

The server didn't send back a proper XML response. Please contact your system administrator.

XML request error: Internal Server Error (500).

Please help me some body.How  i can solve this issue.




Hey there,

I have installed FCK editor.  I have gotten it to work with ASP.net. I have changed skins. I set read/write permission on the folder I want to upload to and its sub folders. I ran it locally but when I run on my site the code it gives the XML error.  I have changed folders around in the config.ascx (UserFilesPath) found in: /fckeditor/editor/filemanager/connectors/aspx/ folder.  The folder fckeditor sits in the following folder:  mysite.com/nbtours.com/.  When I compile my code, and go to the compiled folder of the website the config.ascx is not found there but the dll of it is found inside the bin directory, why so?  If you have the above scanario and you have the folders set like the above what am I missing?




I've got a set of XML Schema files that define the schemas of various custom configuration sections. One of these is CommonTypes.xsd, which, as the name suggests, contains common types shared by the other schemas (via the include attribute). All schemas are in the same local folder.

To validate each respective configuration section (which I do in the respective IConfigurationSectionHandler implementation) I do the following:

1. I Create an XmlDocument
2. I load the relevant XmlSchema (not the CommonTypes.xsd but one referencing it) and add it to the XmlDocument schema collection (XmlDocument.Schemas.Add())
3. When the IConfigurationSectionHandler.Create() method is invoked, I load the section (XmlNode passed to it) into the XmlDocument and call XmlDocument.Validate()

At this point I get an error saying that "Type 't_nonEmptyString' is not declared, or is not a simple type." It is, in fact, declared (in CommonTypes.xsd) and it is also a simple type. Note that the same configuration section validates using other tools such as Altova XMLSpy, so the inclusion of CommonTypes.xsd in other schema would seem to be working as intended.

If I examine the XmlSchema after loading it, I can see that the Includes collection contains a single entry which, upon further inspection, is the referenced CommonTypes.xsd. However, while the XmlSchemaInclude.SchemaLocation is assigned, the XmlSchemaInclude.Schema is not (it is null). Do I need to explicitly load the CommonTypes.xsd schema before validating or what am I missing?


when i debug C# 2005 appear this error D:\MM\obj\Debug\CSC83.tmp' is not a valid Win32 resource file

please! help me!!


I've got a list, that I need to copy to another list.  The contents of my list, are x,y coordinates that I display on a chart. When I switch between charts, I need to clear my list, which clears data from the chart.

Here is what I am doing

Mylist ; // contains my XY data


tmplist = Mylist;

pass the tmplist to my display function.  Works fine the first time, but the second time through mylist is also clear, which is because I'm assinged the address of mylist to the tmp list, so once I clear the tmp list, I also clear mylist.

How do I get around that?  Can i put a list in a for loop, and copy element by element like an array?


I am missing the tmpF7.tmp file that prohibits the uninstall of net programs. I tried finding the uninstaller recommended in an earlier post but the link no longer works. Basically I need to have the tmpF7.tmp file in order to install/uninstall .net software. Any suggestions greatly appreciated.
After upgrading an asp.net application to 2.0 from 1.1 I am receiving a large 100+MB .tmp file in C:\Temp on the web server when the w3wp process serving that application crashes. If you open the file it looks like it is some sort of dump file. Any ideas how to turn this off. I know what is crashing the application and process. Any help is appreciated. Thanks

 After upgrading an asp.net application to 2.0 from 1.1 I am receiving a large 100+MB .tmp file in C:\Temp on the web server when the w3wp process serving that application crashes. If you open the file it looks like it is some sort of dump file. Any ideas how to turn this off. I know what is crashing the application and process. Any help is appreciated. Thanks


We have a WCF windows service. We install this service with service account say e.g. WCF_ServiceAcc

When we start the service a tmp file gets created under the service account.

Sometimes this files grows bigger and the service stops working.

Do let us know why this is happening?



We have a strange issue where our employees are losing their work on a regular basis. Scenario:

Randomly, Word 2010 will fail to save a document and the only thing left behind is a .tmp file with the last version of the document. All of the user's changes since the last save will not be there. The problem is very random though. Our machines are HP desktops or Lenovo laptops running Win7 x64 with Office 2010 x86. ESET is our AV. Our filers are Windows Server 2003 with the actual storage medium being NetApp SANs. We thought it was related to Win7 kb980232 hotfix, alas we've been able to recreate the problem with a clean install of Windows 7 x64 and Office 2010 x86 with no hotfixes and no add-ins installed. If there is interest, I can post the Word macro that we are using to recreate the problem.

edit: We've been able to see that the error being raised is 5096. We have been working with MSFT support on this issue for several months. We're reaching out to see if anyone else has any ideas.



I'm having a bit of trouble finding information related to usage of TMP temporary database files.

Specifically I'm trying to to determine when the SSCE engine would determine they are no longer used and delete them. We need to know whether we will need to manually remove the files.

I'm working with SSCE 3.5 SP2 on a desktop app, specifying the temp folder in the connection string.

Any insight?


I get the following sometimes when I open up a form class in C# VS 2005 .NET:

Message popup box with:

"File Download - Security Warning"

"Name: ######E#.tmp"

"Type: tmp_auto_file, 3.92KB"

"From: local area"


Instead of it opening up the form, but when I close it and try to open it again it may do this again or work fine.

This form does have links in it but not before any activity before I open it in c# VS 2005 .NET.

Not a huge deal, just annoying to cancel out and redo steps to open a form in .NET.



Hi all,

I'm trying to install SQL server 2008 on a Windows Server 2008 SP2 64bit , but I'm facing this error message:

"A network error occured while attempting to read from the file E:\9c......\x64\setup\x64\SQLE86D.tmp.msi"

Have anyone faced the same message before?




I am trying to create a plugin for entity: account.

Purpose: When user changes/enters new emailid , system shall check whether there are existing accounts with the same emailid, if yes then system shall display those onscreen as a alert.


cols = newColumnSet();




ConditionExpression condition = newConditionExpression();

condition.AttributeName =


condition.Operator =


condition.Values =

newstring[] { "test@hotmail.com" };


FilterExpression filter = newFilterExpression();

filter.FilterOperator =



newConditionExpression[] { condition });


QueryExpression query = newQueryExpression();

query.EntityName =


query.ColumnSet = cols;

query.Criteria = filter;


RetrieveMultipleRequest retrieve = newRetrieveMultipleRequest();

retrieve.Query = query;


CrmService service1 = newCrmService();


Response res = service1.Execute(retrieve);




//RetrieveMultipleResponse principalResponse = (RetrieveMultipleResponse)service.Execute(retrieve);


//if (principalResponse.BusinessEntityCollection.BusinessEntities.Count > 0)




// throw new InvalidPluginExecutionException("Duplicate EmailID exists! " + principalResponse.BusinessEntityCollection.BusinessEntities.Count.ToString());




I have tried creating a new CodedUITest in a new Test Project. When I Selected "Record actions,edit UI map or add assertions" radio button on "Generate Code for Coded UI Test" , i am getting error " There was an error generating XML document". I am having Visual Studio 2010 Version 10.0.30319.1 RTMRel.

Could some one help me out on this.



Error 7 Error loading GetData.dtsx: Failed to decrypt protected XML node "DTS:Password" with error 0x8009000B "Key not valid for use in specified state.". You may not be authorized to access this information. This error occurs when there is a cryptographic error. Verify that the correct key is available.   c:\Packages\GetData.dtsx 1 1 

Error 8 Validation error. Data Flow Task: OLEDB Source [5310]: The AcquireConnection method call to the connection manager "SourceServer" failed with error code 0xC0202009. GetData.dtsx 0 0 

Environment I need to execute - BIDS
Have Solution, with files linked with VSS. When I click on package, aforesaid errors show up and package opens in designed.

Protection Level : Encrypt Sesitive with User Key
This means it'd run only on machine and by user where and who created respectively.

So I changed it to Encrypt Sesitive with Passoword and provided Passoword. No luck

So I changed it to Do not save sensitive, as anyways in the connection manager, it has Expression saying @Variablename (with appropriate correct syntax), and variable is mapped to config file. I tired with Config file and also by hardcoding the value in the connection manager's connection string after removing the variable name, also tried by hardcoding value in variable value and disabling config file.

Nothing works.

I read 3 threads discussing this issue by others, and they all focus on SQL Server Agent, creating proxy accounts, etc. Within BIDS, I think I've exhausted all options. Kindly help someone!


I am using a CLR stored procedure to call a webservice. I have marked the project as  strongly named assembly and also created a serialization assembly using Generate Serialization assembly in VS 2008. It created both files which I copied on to the database server. I have created assemblies of both






CREATE PROCEDURE TestList(@date datetime) AS EXTERNAL NAME XXXCLRProcs.[XXXCLRProcs.CLRStoredProcedure].TestList



When I tried to execute stored procedure with @date = N'2000-1-1' I get following error:


A .NET Framework error occurred during execution of user-defined routine or aggregate "TestList": 

System.Exception: Failed to send outbound message There was an error generating the XML document.


   at XXXCLRProcs.CLRStoredProcedure.ConsumeTestList(DataTable dt)

   at XXXCLRProcs.CLRStoredProcedure.TestList(DateTime date)



Here is the code:


   public static void TestList(DateTime date)


            using(SqlConnection connection = new SqlConnection("context connection=true")) 




                string sql = "select distinct e.x_date, e.reg_id, e.reg_eff_id, e.de " +

                                " from   rv_eff e " +

                                " where  e.sys_updt_time >='" + date +"' " ;

                SqlCommand command = new SqlCommand(sql, connection);

                SqlDataAdapter da =new SqlDataAdapter(command);

                DataTable table = new  DataTable();





                    string ret = ConsumeTestList(table);








On further investigation this is the inner exception:


The action that failed was:


The assembly or AppDomain that failed was:

XXXCLRProcs.XmlSerializers, Version=, Culture=neutral, PublicKeyToken=8a327fb4d6c336b8

The method that caused the failure was:

System.String get_RegistrationId()

The Zone of the assembly that failed was:

MyComputer stacktrace    at System.Xml.Serialization.XmlSerializer.Serialize(XmlWriter xmlWriter, Object o, XmlSerializerNamespaces namespaces, String encodingStyle, String id)

   at System.Xml.Serialization.XmlSerializer.Serialize(XmlWriter xmlWriter, Object o, XmlSerializerNamespaces namespaces, String encodingStyle)

   at System.Web.Services.Protocols.SoapHttpClientProtocol.Serialize(SoapClientMessage message)

   at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)

   at InboundService.TestList(TestList TestList1)

   at XXXCLRProcs.CLRStoredProcedure.ConsumeTestList(DataTable dt)


   at XXXCLRProcs.CLRStoredProcedure.ConsumeTestList(DataTable dt)

   at XXXCLRProcs.CLRStoredProcedure.TestList(DateTime date)

Please help me!!!


Hi all,

I'm trying to import the Customizations.xml into one of our environments and I'm getting a generic error.  "Either the file could not be uploaded, or this is not a valid Customizationss file."  The same file works in all of our other environments, just not this one.  All are on rollup 8 (I've uninstalled and re-installed multiple times.)  One difference is this environment was just built from scratch while the rest of our environments have been taking build after build, but all started from the same state with rollup 8 applied.

In the trace logs, I see the following error, however, bing and google aren't helping.
ValidateImportDocument hit exception. Message: The element 'mailmergetemplate' has invalid child element 'entityPlatformName'. List of possible elements expected: 'parameterxml, mailmergetype, templatetypecode, defaultfilter'.

Any ideas?




<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure