Home » MS OfficeRSS

MQSC Adapter Issue: Attempted to read a write protected memory

Hi All,

We recently saw this error on our UAT environment with the MQSC adapter.

 

Event Type: Error
Event Source: BizTalk Server 2006
Event Category: BizTalk Server 2006
Event ID: 5754
Date:  7/7/2010
Time:  8:52:07 AM
User:  N/A
Computer: 
Description:
A message sent to adapter "MQSC" on send port  is suspended.
 Error details: Attempted to read or write protected memory. This is often an indication that other memory is corrupt. 
 

I have found a couple of KB articles that dont directly relate to the MQSC adapter but apply to the OS we are using, i.e. Windows 2003 SP2. Has anyone else encountered this error?

http://support.microsoft.com/kb/923028

http://support.microsoft.com/kb/961180/en-us

Also, the instance is suspended and resumable, but just resuming it does not clear this issue. We had to terminate the suspended isntance and resend the messages.

Just a few details about the environment:

 

1. OS: Windows server 2003 SP2 64 bit

2. BizTalk Server 2006 R2

3. Clustered Node, with MQ host instance active on one node

4. VMWare

Thanks

Reddy

 

4 Answers Found

 

Answer 1

Hi,

A few things,

Ensure the the queue which you are sending to is write  enabled.

Ensure the channelname, queue, and queuemanager info is correct.

Finally, error  might actually exist on Webspere MQ side.  Ensure you have install the correct updates for WebspereMQ 

http://www-01.ibm.com/support/docview.wss?rs=171&uid=swg27006868

Thanks,

William

 

Answer 2

Hi William,

Thanks for the response. Yeah everything is setup correctly. The messages were passing to MQ just fine until this morning, when got an email with the error. I am going to check if there are any logs on the MQ side.


Thanks

Reddy

 

Answer 3

Hi,

That might indicate a change in your environment.  IsWindows Update enable on the machine(s)?  I think the first Tuesday of the month is when Microsoft releases updates.

Thanks,

William

 

Answer 4

Nope, Windows updates on these servers is done manually. No patches or updates are installed without approval. I did check the MQ server  logs... no errors or warnings or anything that would point to a problem. The only thing is that we use a 7.0 MQ client and the server is 6.0.2.4. I have checked the IBM docs and they seem to be compatible.

..well we will keep digging... will let you know if we find a resolution. We did open a ticket with Microsoft.

 

Thanks

Reddy

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter