Home » Microsoft TechnologiesRSS

Problems with AGEIA Physx install in 2008

All,

I reviewed the previous post but am not sure the problem was ever resolved.

In the latest R2 2008 install the AGIEA PhysX ptogram failed to install. I remember AGEIA being present under PROGRAMS> within the Windows startup tree but the new install does not have the reference.

When using the VSE everything is light grey, and does not render. I tried uninstalling and removing all manual entries, but still no AGIEA after install. During the install, the process stops at a screen stating the AGEIA PhysX was 'Pending', click to INSTALL.

Is there another way to test or manually install the PhysX engine?

Best regards,

DrZaeus
 

9 Answers Found

 

Answer 1

:-)

According to my understanding it is no longer AGIEA PhysX but NVIDIA PhysX. So for example I have in my Win 7 RC 32 bit machine NVIDIA GAME System Software 2.8.1 installed.
Are you using Vista/Win 7? Are you installing from a Admin account? and more over try right click on the installer and use Run as administrator option as well.
I'm not sure whether it's OK to install PhysX seperately.
Best Regards
Aravinda D.P.
 

Answer 2

Aravinda,

Thank you for your insight into the changes with the PhysX software.

I noted the name change from AGIEA PhysX to NVIDIA PhysX after the installation when I was troubleshooting my rendering issue on the VSE.

My note is more related to the splashscreen during the R2 install that clearly states loading the AGIEA PhysX and it seems to hang while stating "PENDING". What's going on here and what exactly is it loading? Is there a way to test to see if the software simulation environment is working?

I am running XP and will try to load the NVIDIA PhysX software manually.

Any help is appreciated!

Best regards,

DrZaeus
 

Answer 3

Hi,

You can separately download and install NVIDIA PhysX System Software from here:
http://developer.download.nvidia.com/PhysX/PhysX_Game_installer_281.msi

It will be installed under %ProgramFiles%\AGEIA Technologies\v2.8.1

After you have installed it you should be able to run any of the Simulation Environment samples from the Microsoft Robotics Developer Studio 2008 R2 Start menu.


Thanks,

Omid
 

Answer 4

Omid and Aravinda,

Thank you for your insight. I used the link to download the AGEIA PhysX software and installed the package. The download provides the AGEIA Control Panel has a DEMO tab that will test the install. The is installed as the NVIDIA Game installer 2.8.1.

I tested the application and debugged one issue with the XNA install, updating the installation to Version 3. I am successfully opening all the DSS and launching all of the tutorials and samples but the VSE is still a nice pale purple color.  I tried adjusting the display to a minimal setting with the same result.

I have a few hunches regarding my installation and will update with my progress.

Much thanks,

DrZaeus
 

Answer 5

:-)

Apart from the installation issue can you specify your graphic card? And if you are on XP please make sure System Proprties->Advanced->Performance->Visual effects is not set for the best performance.

Best Regards,

Aravinda D.P.
 

Answer 6

Aravinda,

Thank you for your help. I am running a NVIDIA RIVA TNT2 with updated drivers and the Visual Effects is 'not set' for best performance, but on "let Windows decide".

As I indicated, evrything seems to be running fine except the VSE screen stays a nice light purple shade and never renders.

Much thanks,

DrZaeus
 

Answer 7

:-)

Hmm While I have doubts on conformance of your graphic card with directx 9 shader model 2.0. But did you say VSE was working on previous versions?

Regards,

Aravinda D.P.
 

Answer 8

Hi,

You can separately download and install NVIDIA PhysX System Software from here:
http://developer.download.nvidia.com/PhysX/PhysX_Game_installer_281.msi

It will be installed under %ProgramFiles%\AGEIA Technologies\v2.8.1

After you have installed it you should be able to run any of the Simulation Environment samples from the Microsoft Robotics Developer Studio 2008 R2 Start menu.


Thanks,

Omid

Is it compatible with all windows versions? I'd like to try it, Thanks for your help!
 

Answer 9

Did you try the link? Wasn't working to me.

I'd like to mention that if you have this problem it's hard to come by.

I got this since two month and frequently try out some new set up or settings.

 

The Team did't solved this and made not effort to come by...

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter