Home » SQL Server

SQL Server Management Studio Express 2008 R2 still needs .NET 3.5 SP1

i've installed .NET 4.0 and SQL Server 2008 Express. When i run Web Platform Installer 2.0 to install SQL Server Management Studio Express 2008 R2, i'm asked to install .NET 3.5 SP1. Is this known issue? How to get it around?  Thx!

5 Answers Found


Answer 1

Yes, you need .net 3.5 SP1 if  you plan to use

The CLR data types geometry, geography, and hierarchyid. 

The dynamic management views for assemblies and spatial objects. 

The CLR user-defined types, functions, aggregates, procedures, and triggers

the .net framework 4 is only for runtime only package....


refer to Krzysztof Kozielczyk comments on official sql express blog



Answer 2

i think .NET strictly maintains downwards compatibility, .NET 4.0 should work well for SQL Server Management Studio Express 2008 R2 when the old version 3.5 SP1 works. i'm afraid this it merely installation incompatible issue, isn't?

i don't plan to use CLR related topics, but the installation via Web Platform Installer 2.0 doesn't allow me to choose what functionalities i intend to have on SQL Server Management Studio Express 2008 R2. Is there workaround to avoid install .NET 3.5 SP1 when i've installed .NET 4.0 and full SQL Server Express 2008.


Answer 3

the .net framework 4 is only for SQL Express runtime only, if you need tools or advanced services you still need 3.5 SP1

refer to Krzysztof Kozielczyk's comments on official sql express blog

**all comments in this post apply to .NET Framework 4 RTM and to SQL Server 2008 R2 Express] ***




Answer 4

The link above is somehow outdated.

i searched this http://blogs.msdn.com/b/sqlazure/archive/2010/06/02/10019029.aspx

Any progress out there?


Answer 5

Hi fans,


Is this known issue


Since some components are developed upon Microsoft .net Framework 3.5 SP1, if we want to install SQL Server Management Studio Express 2008 R2 on your machine, Microsoft .net Framework 3.5 SP1 is required.


If you are using Windows 7 or above, we just have to enable it from “Turn Windows features on or off”. Please follow the steps below to enable it:

1.       Run “appwiz.cpl” from windows run dialog

2.       Click “Turn Windows features on or off” in the left pane

3.       In the “Windows Features” dialog, please find “Microsoft .net Framework 3.5.1” out, then check it and click “OK”

If you are using an operating system lower than Windows 7, please download it from following link and install it:



If anything is unclear, please let me know.



I am writing an installer for our product that uses SQL Server 2008 Express SP1 as the database engine.

I do not see a download anywhere for SQL Server 2008 Management Studio Express SP1 - there is only the RTM download.

As far as I understand it, it is not possible to install Management Studio Express 2008 on a machine with the 2008 SP1 database engine.  My installer therefore needs to install MSE first, then the database engine second.  I'm fine with that, but it is possible that the machine already has an instance of 2008 SP1 on it from something else (or a previous install).

So? What am I to do?  How can I install MSE on a machine with the 2008 SP1 Database Engine??

And what the heck was Microsoft thinking by not releasing an MSE SP1 in parallel to the SP1 for the DB engine?  or they could have maybe given us a 2008 SP1 "with tools"...



After I installed SQL Server Express 2008 R2 I realized that if I wanted to use the AdventureWorks sample databases I needed to have SQL Server Express 2008 R2 Advanced Services installed because Advanced Services has full text search installed which is required to install and run the sample databases. I downloaded the installation but nothing happened. So, do I need to uninstall SQL Server Express 2008 R2 and install SQL Server Express 2008 R2 Advanced Services? Or, is there a way I can upgrade my existing installation of SQL Server Express 2008 R2 to SQL Server Express 2008 R2 Advanced Services.



Hi ,

i have install a application that use sql server express 2005 on a server with OS windows server 2008 r2.

My question is how to make automatic backup of my database , because i cant install

SQL Server 2005 ManagementConsoleon my server .


Please help me



Is it ok to use the RTM release of management studio express R2 in a production environment?

When will it be officially realeased? The engine was released on 9/29/2010....



Getting this error "This server version is not supported" after I create a data connection in Visual Studio 2008 SP1 I and SQL server 2008 R2. Any ideas would be great.


Hi all,

I've installed SQL Server 2008 SP1 CU9 developer edition and SQL Server 2008 R2 Express side by side on my machine.

When I try to open/expand SQL server logs node under Management on developer edition instance, I get the following error message:


TITLE: Microsoft SQL Server Management Studio

Failed to retrieve data for this request. (Microsoft.SqlServer.Management.Sdk.Sfc)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&LinkId=20476


An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)


A severe error occurred on the current command.  The results, if any, should be discarded. (Microsoft SQL Server, Error: 0)

For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft+SQL+Server&ProdVer=10.00.2789&EvtSrc=MSSQLServer&EvtID=0&LinkId=20476


The SQL Server Management Studio version is 10.50.1600.1

SQL Server 2008 SP1 CU9 version: 10.0.2789.0

SQL Server 2008 R2 express edition version: 10.50.1600.1 RTM


I don't get that error when expanding SQL Server Logs on express instance, only on the developer edition.

Any ideas how to solve this issue or hints what the cause might be, will be appreciated.




I have installed sql server 2008 r2 developer with its full tool set, finally, and though the sql2008r2 express with advanced tools stated that each instance has its own tools, registry values, etc, I thought it prudent to ask if sql server 2008 r2 express tools would screw up sql server 2008 r2 developer tools (limited functionality afterwards)?

We recently purchased a server that has SQL Server Express 2008 installed. I would like to install SSE 2008 R2. Do I need to uninstall SSE 2008 before installing R2?

There is currently no data in the database(s). I believe it's bascially a fresh install from the factory.

Follow up. I would like to rename the computer. I assume I would want to do this before installing SSE 2008 R2.

Windows Server Standard 2008 SP2
intel Core Duo i5 @ 333 Ghz
64 bit OS

Microsoft SQL Server Management Studio      10.0.2531.0
Microsoft Data Access Components (MDAC)      6.0.6002.18005
Microsoft MSXML      3.0 4.0 6.0
Microsoft Internet Explorer      8.0.6001.18975
Microsoft .NET Framework      2.0.50727.4206
Operating System      6.0.6002

Thank you very much.



I am new to this developing on this platform and having problems at work and home but different problems. 

At work when i try and view the aspx page it says unable to connect to the asp.net development server and also can't add the database to the app_data folder.  Are there problems with visual studio 2008 /Sql server 2008?

set up at  work is below

L-06914  server

Microsoft SQL Server Enterprise Edition

Microsoft Windows NT 5.1 (2600)

At home, I was making a connection and almost bringing up the page  but had an error the next day could not connect inside of sql server 2008. 

At home it is the same except for standard version

server is my computer name

Let me know if more information is needed. Thanks,  SB

Does the Express version of Management Studio support database projects like the full 2005 and 2008 versions do?  Thanks in advance.

I cannot figure it out.

same error as this one.


Has this been resolved.  I do not have the ability to edit the msi, this is a msdn iso.


Please help.



I'm connected to my SQL Azure database. When I right click on the Tables node of my database and ==> New Table, a text query window opens with a generic text template and common CREATE TABLE commands.  

If I am connected to a local SQL database, New Table displays a fill-in-the-column grid and, by the way, the tables created all start with dbo.[TableName].

Why the difference, and can the fill-in-the-Grid approach be made to work with SQL-Azure tables?

Thanks in advance for any help...


I am at my wits end with this!!  I have tried everything.  I have uninstalled all sql server 2005 express programs.  Reinstalled them and then uninstalled them again.

The current state of things is that I have succussfully intalled sql server 2008 express, but when I try to install sql server 2008 express management console.  I get FAILED: Can't install sql server express 2008 management console because sql server 2005 express tools are installed.

Before I installed sql server 2008 express and tried to install sql server 2008 express management console.  I had no MS Sql Server programs visible in the Control Panel (Vista SP 2).  However I still see the shortcut to "C:\Program Files\Microsoft SQL Server\90\Tools\Binn\VSShell\Common7\IDE\ssmsee.exe" in my start ORB.  How can I get rid of it!!??


I just installed SQL Server 2008 R2 Developer Edition on a Windows XP machine and notice the Server Type option is disabled in SSMS. The "Database Engine" option is selected as default and I am not able to change to other options such as Integrating Services.

Is there a setting to enable the Server Type option?

Thank you

I have Sql 2008 R2 active and passive cluster both running management studio on windows server 2008 R2 and firewall is enabled , when i disable the firewall i can open mangement studio from passive node , i have enable firewall on active node and opened all ports required for management studio on active node , i have followed properly below article ports defined by microsoft


and also below article , the only difference is i have changed the default port 1433 to 11433 and allowed this port through firewall for incoming connection for all type of networks , domain , private and all, in advance firewall configuration i have even disabled ipsec , i can telnet from remote port.


now i just want to know if changing the port in sql has any effect for firewall configuration in server 2008  , even i am allowing the port which is changed in sql and after disabling firewall is able to connect through management studio ,

if there is any quick solution , please share with us the information , i have even enabled firewall logging , and it shows odd ports blocked such as 138 and 137 for netbios.

Waiting for Microsoft Response.


Hello All !

I'm installing a log shipping solution with SQL Server 2008 Standard SP1 (on x64 US). I use a monitor logshipping with SQL Server Express Edition x64 SP1 US. When I try to connect it, I have this message when i tried to use w.x.y.z\SQLEXPRESS  as a monitor server:

'w.x.y.z\SQLEXPRESS' is not a valid monitor server instance.  A monitor server instance must be SQL Server Standard Edition, SQL Server Workgroup Edition, or SQL Server Enterprise Edition.'

In SQL 2005, it is possible to do that with SQL Express. And with 2008 R2, is it possible too or it is the same problem ?


I am trying to install sql server 2008 r2 express but keep getting the error "RANU is only supported for sql server express" during the install but that is what I am trying to install.

I tried this using "run as administrator" as well as signing in with the Administrator account

The install stops.

I am using Windows 7 Home Premium 64 bit.

I do not currently have any other sql servers installed. However, I do have sql server 2008 r2 setup installed.

I cannot remove it because I get a message stating that I have sql server 2008 r2 common files installed.

I cannot find these files

how do I uninstall "Management Tools - Basic in SQL Server 2008 R2?  The regular remove program does not have this option highlighted.    I am trying use some of the advance option and learn something more and now ssms is useless.         the discovery report tells me these are installed but I have no way of uninstalling.  .  I want to replace this with my developer edition that I purchased but have lots of trouble installing because of the express version.  Please help.  I'd really appreciate it. "
Sql Server 2008  Management Tools - Basic1033Express Edition10.50.1092.20No
Sql Server 2008  Client Tools Connectivity1033Express Edition10.1.2531.0No
Sql Server 2008  Client Tools Backwards Compatibility1033Express Edition10.1.2531.0No
Sql Server 2008  Client Tools SDK1033Express Edition10.1.2531.0No

I installed a SQL Server 2008 Express R2 on Windows Server 2008 R2 x64 machine on 15th february 2010.

Today I can't start the "SQL Server" windows service. I have tried manually, but the error is:

"Window could not start the Sql Server (SQLEXPRESS) on Local computer"

After trying to start the  the "SQL Server" windows service, I have read on the Event viewer the following error:

"SQL Server evaluation period has expired".

After trying to launch the SQL Management studio Express 2008 I have read this erroe on a pop-up windows:

"Evaluation period has expired."

I though that the express edition was free. I need only to register or to buy?

How can I buy?

I am in hurry. Please let me know! Thank you very much.




I am attempting to upgrade SQL Server 2008 R2 Enterprise edition (64-bit) to service pack 1.  The product version is 10.50.1600.1, which is, to the best of my knowledge, SQL Server 2008 R2, and also, again, to the best of my knowledge, an RTM version (when I run query SELECT SERVERPROPERT('productversion', SERVERPROPERTY('productlevel') in SSMS, the results display as "10.50.1600.1" and "RTM".  I downloaded SQLServer2008SP1-KB968369-x64-ENU.exe.  When I run this application, and get to the "Select Features" dialogue, no instance specific features are displayed (e.g. Database Engine, Analysis Server), Shared Features are displayed but cannot be selected, and when "Next" is clicked, the error "There are no SQL Server instances or shared features that can be updated on this computer".

The OS on which I'm installing the service pack is Windows 2008 R2 Enterprise.

What little I have gleaned from similar postings suggests that the installed version of SQL is not an RTM version.  How can that be, if, the only version I've ever installed on this new (virtual) server is reporting that it is, in fact, RTM?

By the way, I've tried running "Repair" on the 3 installed named instances and the shared features, then reinstalling SP1, with no luck.


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure