Home » SQL ServerRSS

SQL Server Management Studio Express 2008 R2 still needs .NET 3.5 SP1

i've installed .NET 4.0 and SQL Server 2008 Express. When i run Web Platform Installer 2.0 to install SQL Server Management Studio Express 2008 R2, i'm asked to install .NET 3.5 SP1. Is this known issue? How to get it around?  Thx!
 

5 Answers Found

 

Answer 1

Yes, you need .net 3.5 SP1 if  you plan to use

The CLR data types geometry, geography, and hierarchyid. 

The dynamic management views for assemblies and spatial objects. 

The CLR user-defined types, functions, aggregates, procedures, and triggers

the .net framework 4 is only for runtime only package....

 

refer to Krzysztof Kozielczyk comments on official sql express blog

http://blogs.msdn.com/b/sqlexpress/archive/2009/12/09/sql-server-express-and-net-4.aspx

 

Answer 2

i think .NET strictly maintains downwards compatibility, .NET 4.0 should work well for SQL Server Management Studio Express 2008 R2 when the old version 3.5 SP1 works. i'm afraid this it merely installation incompatible issue, isn't?

i don't plan to use CLR related topics, but the installation via Web Platform Installer 2.0 doesn't allow me to choose what functionalities i intend to have on SQL Server Management Studio Express 2008 R2. Is there workaround to avoid install .NET 3.5 SP1 when i've installed .NET 4.0 and full SQL Server Express 2008.

 

Answer 3

the .net framework 4 is only for SQL Express runtime only, if you need tools or advanced services you still need 3.5 SP1

refer to Krzysztof Kozielczyk's comments on official sql express blog

**all comments in this post apply to .NET Framework 4 RTM and to SQL Server 2008 R2 Express] ***

http://blogs.msdn.com/b/sqlexpress/archive/2009/12/09/sql-server-express-and-net-4.aspx

 

 

Answer 4

The link above is somehow outdated.

i searched this http://blogs.msdn.com/b/sqlazure/archive/2010/06/02/10019029.aspx

Any progress out there?

 

Answer 5

Hi fans,

 

Is this known issue

No.

Since some components are developed upon Microsoft .net Framework 3.5 SP1, if we want to install SQL Server Management Studio Express 2008 R2 on your machine, Microsoft .net Framework 3.5 SP1 is required.

 

If you are using Windows 7 or above, we just have to enable it from “Turn Windows features on or off”. Please follow the steps below to enable it:

1.       Run “appwiz.cpl” from windows run dialog

2.       Click “Turn Windows features on or off” in the left pane

3.       In the “Windows Features” dialog, please find “Microsoft .net Framework 3.5.1” out, then check it and click “OK”

If you are using an operating system lower than Windows 7, please download it from following link and install it:

http://www.microsoft.com/downloads/details.aspx?FamilyID=ab99342f-5d1a-413d-8319-81da479ab0d7&displaylang=en

 

If anything is unclear, please let me know.

 
 
 

<< Previous      Next >>


Microsoft   |   Windows   |   Visual Studio   |   Follow us on Twitter