Home » Visual Studio

VS2008 slow debugging

Hi folks,

I am working on a small project in VS2008(4 projects 3 class libraries and one console app).

When i try to debug the program it's extremly slow.

Stepping through the code takes about 1-2 seconds for each step. Weird thing is though that i can see in my file-tabs that the ide locks the files during that second.

What he is doing during that time, i don't know, but i m sure it has something to do with my slow debugging.

Any suggestions?


20 Answers Found


Answer 1


Do you have lot of breakpoints set in your project. That could slow  things down. Also, check the status bar for Visual studio to see if anything is happening during the step operation. It could be that visual studio is downloading symbols, thereby slowing it down. Also, try disabling hosting process through Project->Properties->Debugging->Enable hosting process.




Answer 2

I've a similar issue. A small  solution of 3 class  libraries and 1 web project.

After some tuning I've been able to reach an usable editor speed but when I start debug  I've to wait also for minutes, in output window I see assemblies loading

Auto-attach to process '[2004] aspnet_wp.exe' on machine 'TestMachine' succeeded.
'aspnet_wp.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_32\mscorlib\\mscorlib.dll', Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'aspnet_wp.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_32\System.Web\\System.Web.dll', Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'aspnet_wp.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System\\System.dll', Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.

'aspnet_wp.exe' (Managed): Loaded 'C:\WINDOWS\assembly\GAC_MSIL\System.Design\\System.Design.dll', Skipped loading symbols. Module is optimized and the debugger option 'Just My Code' is enabled.
'aspnet_wp.exe' (Managed): Loaded 'A_b8f539d9_ec96_4468_ab1c_fd46b8678897'
'aspnet_wp.exe' (Managed): Loaded 'M_b8f539d9_ec96_4468_ab1c_fd46b8678897'
'aspnet_wp.exe' (Managed): Loaded 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\hypersic\877e83e7\fa8c362c\App_Web_l9zaulrg.dll', Symbols loaded.
'aspnet_wp.exe' (Managed): Loaded 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\hypersic\877e83e7\fa8c362c\App_Web_p9lfmmfv.dll', Symbols loaded.
'aspnet_wp.exe' (Managed): Loaded 'C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\hypersic\877e83e7\fa8c362c\App_Web_uvzne92q.dll', Symbols loaded.

but after a while I obtain and error stating that is "Unable to start debugging. The web server did not respond in a timely manner.This may be because another debugger is already attached to the web server".

In the output window I see

A first chance exception of type 'System.Threading.ThreadAbortException' occurred in mscorlib.dll
An exception of type 'System.Threading.ThreadAbortException' occurred in mscorlib.dll but was not handled in user code

Some hint?


Answer 3

Please also provide some information regarding what type of project  you're debugging.  C#? VB? C++?

Another option to turn off temporarily (if the project is C# or VB) is "Enable property evaluation and other implicit function calls" in Tools->Options->Debugging.


Answer 4

I'm experiencing the same problem (with a VB.Net Winforms application) -- I've tried both the suggestions  given above of disabling th ehost process & implicit calls, but step over is still very slow, and appears to be proportional to the number of source files  open in the IDE.

I find it strange that the SourceSafe padlock appears/disappears (for projects  not in source control) and disappears/appaers (for projects in SourceSafe) for every open file for each time  the debugger resumes/stops (andmaybe it's this that is having a major impact on performance)

(I should point out that I've eliminated the common causes in the FAQ at http://blogs.msdn.com/jimgries/pages/visual-studio-debugger-faq.aspx)

Answer 5

I'm debugging  a C# application.
In these days I made many tests, I was able to reproduce some scenarios.
- opening an ascx it takes  a couple of minutes, the strange thing  is that devenv seems to do nothing looking at task manager. CPU is near 0% for devenv process...it seems to wait for something.
- Pressing F5 it compiles the 4 projects quickly then devenv seems to do nothing for a couple of minutes (as above) and then a message pops up with the error I described above.
-  if after the above message I repress F5, devenv connects quickly to the web server, IE opens but it takes many times to show the page.


Answer 6


If you move your project  outside of source safe, does this still occur?

Answer 7


Disable Just-My-Code and enable break when thrown for ThreadAbortException. Then, when you run this scenario, the debugger will break at that exception. Since you probably won't have symbols this will drop you into dissassembly. However, the callstack will be valuable. Can you please post that after doing this?


Jackson Davis - MSFT

Answer 8

I've also had this problem with VS2008 professional and a native C++ application (4 static lib projects, one win32 project, an AQTime profiling project  and a setup project).  Theres some fairly extensive c++ template code  in there.

I just discovered that closing the 'autos' debug  window gets rid of the issue.  The 'locals' debug window appears to be fine. 


Answer 9

I also experienced the problem with Vista & Visual Studio 2008. Read some other thread in this forum and discovered that if I close Google toolbar then all is fine!

Answer 10

Had some major VS2008 performance issues on Vista here too.

Turning off the Windows Desktop Management made a huge difference in performance. (Shortcut -> Properties -> Compatibility)

Sure you miss out on the fancy Aero stuff, but thats a trade-off I guess.

Start time  of VS2008 decreased from about 90secs to around 5secs. Building goes twice as fast, and debugging: "delay? what delay!?"


Answer 11

I had the same slow  debugging experience - Vista SP1 with VS 2008 SP1. It was taking about 1 or 2 seconds for EACH step through when debugging.

I had a Watch window open and about 5 items that were unrelated to the project  in question.

Closed the Watch window, and the slow debugging  disappeared.

Answer 12

Yes!  We have Visual Studio 2008 SP1.  Starting and exiting debugging  of a C# ASP.Net application was taking minutes.  I deleted all breakpoints, after which the browser and application load in 5 seconds or less.  Apparently we had quite a number of breakpoints, most disabled.  This solved the problem!

Answer 13

I was also experiencing very slow  debugging of a C# project, up to 30 seconds per step-over call.

I am using VS2008 Development Edition SP1.

My solution has:
14 C# projects
1 C++/CLI project
2 Setup projects

All the projects  except the setup projects are configured to build in the debug  build in the Configuration Manager.

None of the above solutions worked for me...

I managed to solve the issue by unloading both setup projects before starting the debugging  session, back to lightning fast!
If I reload the setup projects, debugging goes back to super slow.

I don't want to guess why this solution works for me, it should be completely unrelated, but it may help someone else...

Answer 14

I also have similar problem with VS 2008 (and SP1 as well). debugging  unmanaged C++ heavily-templated code  is very very slow. Stepping either in source window or in disassembler takes  several seconds. Closing Auto, Locals and Watch does not help (but it lowers the delay to some point). Only a single breakpoint (or no breakpoints at all) is defined.

Another problem with heavily templated code is that it looks like a Disassembler window has an internal limit on maximum identifier length, so when a "call" instruction is displayed that refers to a particular long identifier name, no identifier name, and even no address is displayed - just the "call" instruction itself!

This problem, and slow  down did not occur in VS 2005.

The interesting part is that sometimes, if during debugging I switch to another window, do something, switch to something else etc. and then switch back to the pending debugger, it starts working  as a rocket! Like it was some lock a debugger had to acquire each step and now it is gone!

The project  being debugged does not do or initiate any network or inter-process communications, it's just a simple console  app.

And to finish a "bug report" - starting from SP1 command "Step to cursor" crashes the Visual Studio.

OS - Windows XP.

Answer 15

I unchecked the Edit and Continue from the debugging  options.  That fixed my slowness with Visual Studio 2008 debugging.

I also removed the google toolbar from IE and noticed a faster loading response from pages within the VS 2008 web application.

Answer 16

I was finding that stepping  while debugging  a native C++ application was taking up to a second.  I closed all other source file windows except the one I was stepping through and it became perfectly responsive again.

Answer 17

Hi All,

I've noticed in VS 2008 that if you have the 'Show Threads in Source' button selected in the debug  toolbar that stepping  can be at least 10 times slower.

I've also noticed that if your application takes  a long time  to start in debug mode that this can be resolved if you simply 'Delete All Breakpoints' under the Debug menu. This solved an annoying problem for me even though I only had a handful of breakpoints at the time.


Answer 18

My Setup:

Visual Studio 2008 + Service Pack (and all the latest updates) Windows 7 x86_64 Mostly Native C++

I'm not sure if this thread is still alive, but for educational purpose, I want to mention that for Native C++ projects  with multi-threads, if you have "Show Threads In Source" enabled (either right-click on Auto, Local, or Threads panel) you will get about 1-2 seconds delay per stepping.


Answer 19

Thank you CodeMonkeyNinja!!

I had this problem too suddenly, after working  fast before (VS2008/VB.NET WebProject)

"Show Threads In Source" enabled is the solution


Answer 20

Finally a fix to this problem!! It was that sneaky "Show Threads in Source" button. Debugging was painfully slow. Now it's back to normal.


Thanks for posting the answer to my problems (of the moment)


VS2008 C++, WinXP


Hi all,

I am building a website with extensive usage of jQuery to interactive with server side code to achieve Ajax. I lauch my project from VS2008 SP1 in debug mode, and my web app is displayed in IE8. Inside IE8 I hit F12 to launch developer tool, in the developer tool I click on "Script" tab, but when I click "Star Debugging" button I get error message "Unable to attach to the process. Another debugger might be attached to the process."

I launch IE8 to load any other website, repeat the steps to enable JavaScript debug and it works for me. It seems that VS2008 holds the IE process.

In VS2008->Tools->Options->Debugging->Just-In-Time I clear the check box of Script, but I still have the same error when I try to start client debug.

Anybody has clue, how can I enable JavaScript debug from IE8 developer tool when I launch the website from VS2008 debug mode?


I started a new windows mobile application on VS2005 and desided to upgrade to VS2008 and it appears to be a mistake!

It is a Windows Mobile 5 .NETCF 3.5 application and it takes about 90 seconds to compile on VS2008! On VS2005 it took about 30 seconds (and that seemed way to long).

It can't be the machine (about 6 months old, Intel Core 2 duo, 2 Gigs RAM, RAID0 strip harddrives).

Nothing else is going on on the machine. When I compile, in Task Manager, CPU usage on both CPU's hovers around 50% for the 90 seconds.

The application is very small ; it has 7 screens, a few utility classes, 35 xsd datasets, 1 web service reference, 1 image, 1 icon and 1 database.

The resulting executable is 1.2 megs.

Everytime I compile it takes 90 seconds to build, then about 20 seconds to deploy to the emulator. This is unbearable and total unproductive.

What can I do to fix this?

Thanks for your help,


I have installed VS2008 on a Win 7 (64 bits) HP Pavilion dv6 (Quad core i7) laptop. I complied a C++ project (no MFC no C# just plain C++) and it took 3.5 minutes to compile it. I updated VS2008 with SP1 and MSDN SP1, and now it take 8.5 minutes to compile the same project.

I can not figure what is going on. Why it is now taking almost three time longer to compile same project? No changes to the project, just VS SP1 update. Any help greatly appreciated.



We are so happy with all the new stuff on the C++ side in VS2010. Looked forward to the performance gains we could get with rvalue reference using string.

But when we measured performance it turned out that performance of our apps decreased :(

Turned out that sprintf functions are 30 to 100 percent slower when compiled with Visual Studio 2010 compared to Visual Studio 2008 SP1.

This sample app is more than twice as slow when compiled in VS 2010 compared to VS2008. x64 Release. 

It is 30% percent slower when using the "%s" line instead.

// StringPerfTest.cpp





int_tmain(int argc, _TCHAR* argv[])


      charInputString[25] = "A text to be inserted";

      DWORDdw = 1;



      for (DWORDi = 0; i < 10000; i++)


            sprintf_s( ResultString, "%s", InputString );

            //sprintf_s( ResultString, "%d %d", dw,dw );


      return 0;


It's just a tiny little function, but instead of the expected performance gain our overall performance went down 10%.

Hope someone can help us out!

Regards Björn



After migrating a WinForm application with usercontrols that loads dynamically from VS2003 to VS2008 the usercontrols became extremly slowly when moving or resizing.

Gratefull for help and tips


Hi all.

I've got a problem - after installing vs2008 sp1 beta I've lost ability to debug code on IIS. I have a wcf service published there and when I launch test app to test service & attach to aspnet_wp.exe stduio says that no symbols were loaded for source code of my wcf service. everything is up-to-date (code in studio & published one). on iis & in web.config I have debugEnabled set to true.

Does anyone have a solution?



The systemis Win7 x64.  VS2008 SP1, with the following installed on top of that:

KB971092 - Hotfix for MS VS2008 Pro

KB972222 - Security Update for MS VS2008 Pro

I first experienced this with my main (large) project, so I then created a very small MFC dialog project with one button using the VS2008 App creation wizard. 

The problem is this:  When built for Win32 platform: Set a breakpoint.  Hit the breakpoint.  F10 to step over the next line of code: produces access violation exception.  If, instead of stepping with F10, I just continue with F5, no exception.    Nor does anything wrong happen if I just let the program run with no breakpoints.

When I rebuilt the app for x64 platform and repeat the procedure, no exception.  I am able F10 my way through the code. 

The code that is being stepped thru is trivial.  As I said, it is a one-button dialog, and I set the breakpoint inside the handler for the button click:






          int i;

          i = 1;    // <-- Breakpoint is set here.

          i = 2;


Break here, F10 and the result is an exception dialog saying: Unhandled exception at 0x03b5f77b in TestProject.exe: 0xC0000005: Access violation.

I believe the F10 is trashing the stack, because if choose to "break" when the exception dialog is displayed, the call stack shows me still at the line where the breakpoint is.  If I F10 *again*, it puts me inside the afx function that called OnBnClickedButton1(), _AfxDispatchCmdMsg. And OnBnClickedButton1() is no longer even on the stack.

Again, this does NOT happen if built for x64.


I have been reading a lot of blogs, website, MSDN questions etc. to get debugging of the .NET Framework assemblies to work, but none of the solutions worked for me.

When I choose "Load Symbols" > "From Microsoft Symbols Server" it looks like it is working as my call stack turns from gray into black, but when I double click on a line from the Framework it just says "There is no source code available for the current location.".

I am running Windows 7 with VS2008 SP1.

What could be wrong with my setup?
And how do I get it to work?

Best Regards

hi all,

im (like a lot of other people) doing my first steps in vs2010.

one of the things i just found which really annoys me is that each time i try to debug a WPF application the ide slows down so each movement from one statement to the other results in 10 sec. (!) waiting.

what can i do ? is there a nice solution (besides not using WPF:)



Good day,
I have an ASP.NET application that isn't too big, 10 pages and a moderate amount of code behind. When I run the app in debug mode it takes over a minute to load the symbols, about 75 seconds consistently, which seems excessive to me. This of course leads to the issue of the browser doesn't open until the symbols are done.

Here are some particulars concerning my environment. The machine is a P4 2.8 with plenty of resources. I haven't had any issues with it recently. I recently installed SP1 for VS2005. I also have VS 2003 on the same machine and it runs fine and takes about one second to load all of the symbols. The debugging is only local on the one machine. When I start the app without debugging (CTRL-F5) it starts up in about a second or two. This is how I have been debugging recently rather than stepping through code. Just trading one source of pain for another. I did try running the install of VS2005 again in maintenance mode with no change in performance.

Below is the text from the Modules window is VS2005. Sorry for is being so mangled. Having read, it feels like, every post in here that seemed to have anything to do with this issue, I don't think there is anything unusual here. Thanx for any assistance you can provide.

mscorlib.dll C:\WINDOWS\assembly\GAC_32\mscorlib\\mscorlib.dll Yes No Skipped loading symbols.  1 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:15 PM 790C0000-79BA6000 [3696] WebDev.WebServer.EXE: Managed 

 WebDev.WebServer.EXE C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\WebDev.WebServer.EXE Yes No Skipped loading symbols.  2 8.0.50727.762 12/2/2006 5:36 AM 00400000-00420000 [3696] WebDev.WebServer.EXE: Managed 

 WebDev.WebHost.dll C:\WINDOWS\assembly\GAC_32\WebDev.WebHost\\WebDev.WebHost.dll No No Cannot find or open the PDB file.  3 8.0.50727.42 9/23/2005 5:20 AM 5DED0000-5DEE0000 [3696] WebDev.WebServer.EXE: Managed 

 System.Windows.Forms.dll C:\WINDOWS\assembly\GAC_MSIL\System.Windows.Forms\\System.Windows.Forms.dll Yes No Skipped loading symbols.  4 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:17 PM 7AFD0000-7BC56000 [3696] WebDev.WebServer.EXE: Managed 

 System.dll C:\WINDOWS\assembly\GAC_MSIL\System\\System.dll Yes No Skipped loading symbols.  5 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:16 PM 7A440000-7ABFE000 [3696] WebDev.WebServer.EXE: Managed 

 System.Drawing.dll C:\WINDOWS\assembly\GAC_MSIL\System.Drawing\\System.Drawing.dll Yes No Skipped loading symbols.  6 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:17 PM 7ADE0000-7AF74000 [3696] WebDev.WebServer.EXE: Managed 

 System.Web.dll C:\WINDOWS\assembly\GAC_32\System.Web\\System.Web.dll Yes No Skipped loading symbols.  7 2.0.50727.210 (QFE.050727-2100) 1/10/2007 5:25 PM 65F20000-66A72000 [3696] WebDev.WebServer.EXE: Managed 

 System.Configuration.dll C:\WINDOWS\assembly\GAC_MSIL\System.Configuration\\System.Configuration.dll Yes No Skipped loading symbols.  8 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 64890000-6497E000 [3696] WebDev.WebServer.EXE: Managed 

 System.Xml.dll C:\WINDOWS\assembly\GAC_MSIL\System.Xml\\System.Xml.dll Yes No Skipped loading symbols.  9 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:18 PM 69BE0000-6A148000 [3696] WebDev.WebServer.EXE: Managed 

 System.Web.RegularExpressions.dll C:\WINDOWS\assembly\GAC_MSIL\System.Web.RegularExpressions\\System.Web.RegularExpressions.dll Yes No Skipped loading symbols.  10 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 69890000-698D0000 [3696] WebDev.WebServer.EXE: Managed 

 Microsoft.JScript.dll C:\WINDOWS\assembly\GAC_MSIL\Microsoft.JScript\\Microsoft.JScript.dll No No Cannot find or open the PDB file.  11 8.0.50727.42 9/23/2005 2:34 AM 5E600000-5E6BA000 [3696] WebDev.WebServer.EXE: Managed 
 VJSharpCodeProvider.dll C:\WINDOWS\assembly\GAC_32\VJSharpCodeProvider\\VJSharpCodeProvider.dll Yes No Skipped loading symbols.  12 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 6C3B0000-6C3D8000 [3696] WebDev.WebServer.EXE: Managed 

 CppCodeProvider.dll C:\WINDOWS\assembly\GAC_MSIL\CppCodeProvider\\CppCodeProvider.dll No No Cannot find or open the PDB file.  13 8.0.50727.762 12/2/2006 5:23 AM 5B300000-5B31C000 [3696] WebDev.WebServer.EXE: Managed 

 App_Code.lpt2etxi.dll C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Code.lpt2etxi.dll No Yes Symbols loaded. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Code.lpt2etxi.pdb 14 2/28/2007 8:29 AM 00D50000-00D5C000 [3696] WebDev.WebServer.EXE: Managed 

 Microsoft.VisualBasic.dll C:\WINDOWS\assembly\GAC_MSIL\Microsoft.VisualBasic\\Microsoft.VisualBasic.dll Yes No Skipped loading symbols.  15 8.0.50727.42 (RTM.050727-4200) 1/10/2007 5:24 PM 5E410000-5E5BC000 [3696] WebDev.WebServer.EXE: Managed 

 System.Data.dll C:\WINDOWS\assembly\GAC_32\System.Data\\System.Data.dll Yes No Skipped loading symbols.  16 2.0.50727.42 (RTM.050727-4200) 1/10/2007 2:16 PM 65140000-657A8000 [3696] WebDev.WebServer.EXE: Managed 

 App_global.asax.7xffqv5i.dll C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_global.asax.7xffqv5i.dll No Yes Symbols loaded. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_global.asax.7xffqv5i.pdb 17 2/28/2007 8:29 AM 00DB0000-00DBA000 [3696] WebDev.WebServer.EXE: Managed 

 ExceptionHandler.DLL C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\assembly\dl3\7639dd36\00e51216_78cfc601\ExceptionHandler.DLL No No Cannot find or open the PDB file.  18 1.0.2437.19305 9/3/2006 10:43 AM 11000000-11008000 [3696] WebDev.WebServer.EXE: Managed 

 System.Web.Mobile.dll C:\WINDOWS\assembly\GAC_MSIL\System.Web.Mobile\\System.Web.Mobile.dll Yes No Skipped loading symbols.  19 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 695A0000-697DA000 [3696] WebDev.WebServer.EXE: Managed 

 App_Web_go2nuzei.dll C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Web_go2nuzei.dll No Yes Symbols loaded. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Web_go2nuzei.pdb 20  2/28/2007 8:30 AM 00E00000-00E28000 [3696] WebDev.WebServer.EXE: Managed 

 App_Web_iccp.master.cdcab7d2.cycmyovv.dll C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Web_iccp.master.cdcab7d2.cycmyovv.dll No Yes Symbols loaded. C:\WINDOWS\Microsoft.NET\Framework\v2.0.50727\Temporary ASP.NET Files\pir\d052f938\180a09a1\App_Web_iccp.master.cdcab7d2.cycmyovv.pdb 21 2/28/2007 8:29 AM 044B0000-044BE000 [3696] WebDev.WebServer.EXE: Managed 

 System.Transactions.dll C:\WINDOWS\assembly\GAC_32\System.Transactions\\System.Transactions.dll Yes No Skipped loading symbols.  22 2.0.50727.42 (RTM.050727-4200) 1/10/2007 5:25 PM 67AF0000-67B9C000 [3696] WebDev.WebServer.EXE: Managed 


If I have a solution (C# Windows Forms application) containing more than one project I thought that Visual Studio (2008 Pro) would allow me to configure the build environment so that my Debug output directory would contain debug versions of my EXE and DLLs, and the Release output directory would contain release versions of my EXE and DLLs.

Instead, what I actually see is that the Debug output directory is as expected, but the Release directory contains a release EXE but debug DLLs (not release DLLs). Seems like when you refererence is fixed to one version of DLL only.

Can what I want be done easily?


I am running VS2008 SP1 on Win2008R2 X64 (Intel Xeon with 4gb ram).   I have a WCF solution containing a winform client project and a WCF service project hosted in IIS7.  I have the solution set to start multiple projects (the winform client and the wcf service project hosted in iis7).  Here is what happens when I start a debug session.

1. Message box (The target assembly contains no service types.  You may need to adjust the Code Access Security policy of this assembly.

2. System tray message:  Your services have been hosted.

3. 3-5 minute pause before my winform client displays.


Once my client starts, everything works fine but I sure don't care for the 3-5 minute delay waiting for the client to display.   There's no fancy startup code in my client.  I just click a button the form and it invokes the wcf service.   Has anyone else experience slow startup times when debugging their IIS hosted service in VS2008?



I have not been able to get classic ASP debugging to work in vs2008 sp1, no matter what I have tried. I have followed all the steps in Mikhail Arkhipov's posts. I am running on XP SP2 and have tried attaching to the dllhost.exe with both the automatic setting and the manual script setting. What could I be missing???

More info:

 I used Open Web Site to open the classic ASP site from my local IIS in VS2008 and create a solution.

The vitual directory has ASP client and server side debugging enabled. I don't know if any of the other virtual directory options would make any difference (application protection, execute permissions, local path access settings, etc.)

I restarted my local IIS just to make sure everything is clean.

I set a breakpoint in the ASP page I need to debug. It is a large site that requires logging in and a few levels of navigation to get to the page I'm trying to debug.

At this point the breakpoint is a solid red circle.

I used 'Start Without Debugging' to open the site in a browser.

I used 'Debug->Attach to process' to attach to the dllhost.exe that has Script next to it.

Then, the breakpoint hollows out and has a yellow exclamation point icon. The tooltip says 'the breakpoint will not currently be hit. the document is not loaded.'

I navigate to the page I need to debug,  and it shows up in VS2008 Solution Explorer under the Script Documents node. However the breakpoint is not hit, and the tool tip still says that the document is not loaded.

I have also tried the technique of putting a STOP statement in the code, and then trying to attach a new instance of VS2008. This method gives me a message saying that the source cannot be located.


The Microsoft Visual C++ Debug Library Dialog does not appear on any computer in our office that previously had VS2005 installed.
We are currently using VS 2008, and the dialog will not not appear if IE 8 is installed. We are using XP 64bit SP2.


I can reproduce this problem by

Install XP64 SP1 on a computer.

Install VS2005

Uninstall VS2005

Install VS2008

run our test program (source below)

#include <stdlib.h>

int main ()

 char * p = ( char * ) malloc ( 20 );
 * (p - 1) = 99;
 free ( p );

  return 0;

This will bring up the Microsoft Visual C++ Debug Library


Install IE8

Run the test program - Dialog never appears, and the program hangs

Anyone know of a workaround? Removing IE 8  does not fix the problem.


It looks like IE8 breaks the debugger. Interesting this only happens if VS 2005 was previously installed. If I start from a clean machine install VS2008 then IE8 then I don't have a problem.



Any tips on what is making the project so slow.  I have about 5 report server projects, and about 3 other projects. One for My Generation and another Base Class project with one form. My machine is a 2.0 Intel with 1 gig of ram.

Some times hitting enter causes a huge delay or selecting a chunk of code (10 - 20 lines) and doing a ctrl-c causes a huge lag and then again when I do a paste.

Trying to debug by step thru no longer lets me do edit and continue. I get the error "Cannot currently modify this text in the editor. It is read only"

Compiling a 6 meg project after simple changes takes a minute or two to come up.

Is it a sourcesafe issue? References? Mcafee Anti virus?




On my desktop machine, my VS2008 has the option "Emit debug information" in the "Publish Web Site" option.  But this option is not on my laptop.

Where can I turn "on" this option?  I tried to search for this on Google and found nothing.  Any help will be appreciated.


Recently, one of my VS solutions has gotten really slow to start-up and stop a debugging session.

I can't say if it happened suddenly. I don't recall a particular instance when it started but it was definitely in the last week. Whereas before when I would click "Start Debugging" it would take 20, maybe 30 seconds until I can use the application. Now it takes at least 80-90 seconds. Even more odd (to me), is that quitting a debugging session (either by stopping it or closing from within the app) takes 60+ seconds whereas before it was usually just a few seconds. In addition, during the start-up and stop VS is not doing much. No activity in the output window, hard drive is barely working, but one of my CPU's is running 100%. Just building the project takes less than 20 seconds (depending on the last changes) and when starting a debugging session it's about a minute between the end of compiling and when the various symbols start to load.

As mentioned it is just in this one solution. Is there a setting in VS that I might have inadvertently changed? What might be causing these delays?

I can handle a longer time to start the debugger, but taking over a minute for VS to become responsive after stopping the debugging session doesn't seem right to me.

Thanks for any help,


Other info:
- One WPF C# project in the solution
- Using the entity framework.
- Computer is a T9300 2.5Ghz with 4Gb ram laptop



Our prodject is from VS2005 and .NET1.1,

And have been upgrade to VS 2008 and now to VS2010

When upgrading from VS 2008Pro to VS2010Pro, I put in an new DropDownList in one old page and in .cs

DropDownListTeams.DataSource = gerTeams();


Tryed to Build or run the prodject i got error

The name 'DropDownListTeams' does not exits in the current context "MatchScheme.ascx.cs 351"

I can se some times that VS complains sometimes OnSelectedIndexChanged="DropDownListLeague_SelectedIndexChanged"

or similar in diffrent pages  with same error.

Best regards




I am using BIDS / SSIS 2005.  I have a large package that runs very smoothly and fairly quickly when run in debug-mode through BIDS.  When I actually deploy the package to SSIS and execute it using either DTExec or DTExecUI it is WAAAAYYY slower than when run from the development environment.  So slow that I become convinced it is hanging on steps that execute very very quickly in BIDS.  I have read this thread -> http://social.msdn.microsoft.com/Forums/en-US/sqlintegrationservices/thread/5585fa13-dd15-4406-9d4a-e993f2af5929 which has not helped.

I understand that DTExec would be faster than DTExecUI because the former does not have to deal with the GUI component but I would have expected both (and especially DTExec) to be faster than running in debug from BIDS.

I realize I am not providing a ton of detail here, problem is I just don't know where to start... any advice on what I should be looking at to improve package execution through DTExec and / or DTExecUI would be greatly appreciated.  Why would DTExec be so much slower than BIDS Debug???

Thanks in advance..

- Charles

I am trying to debug a design-time problem with my component code using the following process in VS2008:

1. Open the component solution to debug in one instance of Visual Studio .NET. 2. Set a second instance of Visual Studio .NET as your debug application by going to Project | Properties | Configuration Properties | Debugging and setting the following properties: a. Set "Start external program:" to C:\Program Files\Microsoft Visual Studio 9.0\Common7\IDE\devenv.exe b. Set "Command line arguments:" to the .sln 3. Choose Set As StartUp Project on the component project. 4. Set a breakpoint in the component. 5. Use Debug | Start (F5) to begin debugging. 
When I do this I get an exception before the second instance of VS opens:

System.NullReferenceException crossed a native/managed boundary
  Message="Object reference not set to an instance of an object."
       at Microsoft.PowerCommands.Commands.ShowAllFilesCommand.CanExecute(OleMenuCommand command)
       at Microsoft.PowerCommands.Commands.DynamicCommand.OnBeforeQueryStatus(Object sender, EventArgs e)
       at Microsoft.VisualStudio.Shell.OleMenuCommand.get_OleStatus()
       at Microsoft.VisualStudio.Shell.OleMenuCommandService.Microsoft.VisualStudio.OLE.Interop.IOleCommandTarget.QueryStatus(Guid& guidGroup, UInt32 nCmdId, OLECMD[] oleCmd, IntPtr oleText)
       at Microsoft.VisualStudio.Shell.Package.Microsoft.VisualStudio.OLE.Interop.IOleCommandTarget.QueryStatus(Guid& guidGroup, UInt32 nCmdId, OLECMD[] oleCmd, IntPtr oleText)

What can I try to get this to work, or to otherwise debug design-time failures in my C# controls?


<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure