Home » MS Office

VS2010 crashes when typing some keywords


when I type certain keywords (struct, for instance) or IntelliSense comes up because I type a . (dot) in the C# IDE,
my visual studio spontaneously either freezes or crashes with one or more exception messages.
This happens in both C# Console Application Projects and C# WPF Projects.

What can I do to stop this happening?
PS: I have ReSharper Beta installed, the problem DID exist before I installed it, so I doubt that this is the cause.

3 Answers Found


Answer 1

Intellisense has been reported as crashing VS a lot.  Have you tried applying any of the fixes that have been discussed on the MSDN homepage and made available via hotfixes?  Here's some starter links:


Michael Taylor - 3/1/2010

Answer 2

Thank you for your help, I am downloading and installing it right now.
If it works, I will mark your post as answer.

edit: success.

Answer 3

Intellisense has been reported as crashing VS a lot.  Have you tried applying any of the fixes that have been discussed on the MSDN homepage and made available via hotfixes?  Here's some starter links:


Michael Taylor - 3/1/2010

I'm a beginner, It's very useful, Now I have a more clear idea about it.

Like MS help2, can F1 help in vs2010 links to subtopics in help htmls?



I am trying to make a VS2010 project to compile a language called ooc but I have lots of issues.
The first one is the fact that it's using stdbool that is not provided by MSVC so I have added a simple file
with the following content :

#pragma once
#ifndef _STDBOOL_H
#define _STDBOOL_H

#define bool _Bool
#define true 1
#define false 0
#define __bool_true_false_are_defined 1


Then in the source code I have something like :

typedef bool lang_types__Bool;

And compiler is not happy with that :


1>c:\home\vincent\projects\rock\build\c-source\sdk\lang\types-fwd.h(22): error C2061: syntax error : identifier 'lang_types__Bool'

I am compiling in C mode and I don't understand why this simple piece of code doesn't compile.
I should be able to use the following keywords in a C program : true, false, bool, this, class, new


By the way VS2010 is really buggy compared to VS2008 because :

1) Very often some MSBuild process are getting zombie and I have weird messages about precompiled headers

2) The icon inside the Build Toolbar is not refreshed when I launch a compilation so sometimes I cannot stop it, I have to right click on the project and click on Cancel.
3) I get a message about memory when I want to copy/paste some text.

The good point is you have included stdint.h (I think it was not the case with previous version).






I have a class implemented from CompoundValue class


publicclassUser : CompoundValue
   public string FirstName { get; set; }

Spec Explorer crashed when I explore the model. Please help, thanks.


FATAL ERROR: compound value type 'CommonModules.User' not registered (analysis of type usage incomplete?)


at Microsoft.SpecExplorer.VS.SpecExplorerPackage.RecoverFromFatalError(Exception exception)

at Microsoft.SpecExplorer.RecoverFromFatalErrorEventObserver.HandleEvent(ExplorerEvent e)

at Microsoft.SpecExplorer.EventManager.HandleEvent(ExplorerEvent e)

involved exception: Microsoft.Xrt.RecoverFromFatalErrorException: compound value type 'CommonModules.User' not registered (analysis of type usage incomplete?)

at Microsoft.Xrt.ConsoleDiagnostics.FatalError(Exception exception, String message)

at Microsoft.Xrt.ComponentBase.FatalError(String format, Object[] args)

at Microsoft.Xrt.Background.GetConstructorInfo(IType type)

at Microsoft.Xrt.Background.AssertTypePredicateAxiom(DomainPredicateInfo info)

at Microsoft.Xrt.Background.ReducePredicateInfos(Dictionary`2 infos)

at Microsoft.Xrt.Background.GetDomainPredicate(IType type)

at Microsoft.Xrt.Background.GetTypeAndDomainConstraint(IType type, IntPtr term)

at Microsoft.Xrt.Background.Variable(IType baseType, UInt32 index, String baseName, Boolean assertDomainConstraint)

at Microsoft.Xrt.State.ActiveState.NewLogicalVariable(IType type, String baseName)

at Microsoft.ActionMachines.Cord.RuleMachineConstructProvider.RuleDescriptor.<Instantiate>d__e.MoveNext()

at Microsoft.ActionMachines.RuleMachine.ActivationControlState.<GetSteps>d__24.MoveNext()

at Microsoft.ActionMachines.DeclarationMachine.DeclarationControl.<GetSteps>d__7.MoveNext()

at Microsoft.ActionMachines.ParallelMachine.ParallelControl.<GetCommonSteps>d__2a.MoveNext()

at Microsoft.ActionMachines.ParallelMachine.ParallelControl.<GetSteps>d__9.MoveNext()

at Microsoft.ActionMachines.DeclarationMachine.DeclarationControl.<GetSteps>d__7.MoveNext()

at Microsoft.ActionMachines.Explorer.OpenState.MoveNext()

at Microsoft.ActionMachines.Explorer.OpenState..ctor(Nullable`1 incomingAction, MachineState state, OpenState previousState, Explorer explorer, Boolean isStart, Int32 pathBound)

at Microsoft.ActionMachines.Explorer.CreateInitialFrontier(IMachine machine, ICompressedState iniState)

at Microsoft.ActionMachines.Explorer.Explore(IMachine machine)

at Microsoft.SpecExplorer.ExploringOperator.Explore()

at Microsoft.SpecExplorer.RemoteExplorer.Explore(IMachine machine, IConfiguration config)

at Microsoft.SpecExplorer.RemoteExplorer.Work()



Hello. I have a problem with Form designer. I have inherited 'form2' from 'form1' in app project 'MForms'. Form1 has public component 'itemClassContainer'. This component declared in 'MComponents' dll project and has automatic ItemClass[] property with [DesignerSerializationVisibility(DesignerSerializationVisibility.Content)] attribute. ItemClass code:

public class ItemClass { public int a { get; set; } }

Solution rebuilds fine, but after rebuild its impossible to open Form2 designer. Error : Object of type 'MComponents.ItemClass[]' cannot be converted to type 'MComponents.ItemClass[]'. Is it only one acceptable way to fix it - close all files in VS and restart it, when reopen Form2 designer. Until next rebuild designer will work fine.

Can somebody give a solution for this problem ? I guess using different projects makes the problem, but it's impossible to put all projects in on due to some reasons.

 I'm running on Win7 x64 , MVS 2008. Sample project.








On AdCenter UI we can see that each keyword has 3 search match types "Exact", "Phrase", and "Broad" how can i know using the API which types are checked.?

When i check the Keyword object i can see that sometime the Bid.Amount is null, and sometime it is empty but i don't understand this behavior can you explain it a bit?

When Negative keywords are added at the campaign, ad group, or individual keyword level,it does not return individual negative keyword Id,like for eg if it is added at campaign level,it only returns the campaign id,but does not return negative keyword id  in case of multiple negative keywords are added,so the problem is if i want to delete individual negative keyword,how will it be done since negative keyword id is not assigned to it.

I have a VS2008 installation where I customized my IDE. Then I exported the settings and tried to import to VS2010. The VS2010 crash when I try to import settings and to workaround I have to use devenv /restarsetting to get VS2010 work again.
Any idea?

I have VS2010 installed on XP Pro, it crashed when start debugging a small report.  It was working fine the first day installed, it start crashing after 8 hours or so.  No change was made after it was install beside the project. 

Developed a new C# WinForms project in VS2010. Finished the project, deployed to the customer and today when I opened it to make a change VS started crashing whenever I click on a component in a particular custom dialog. No error message other than the standard "I've crashed" dialog., Any idea where to begin?

 Microsoft Visual Studio 2010
Version 10.0.30319.1 RTMRel
Microsoft .NET Framework
Version 4.0.30319 RTMRel

Installed Version: Professional

Microsoft Office Developer Tools  
Microsoft Office Developer Tools

Microsoft Visual Basic 2010  
Microsoft Visual Basic 2010

Microsoft Visual C# 2010  
Microsoft Visual C# 2010

Microsoft Visual C++ 2010  
Microsoft Visual C++ 2010

Microsoft Visual F# 2010  
Microsoft Visual F# 2010

Microsoft Visual Studio 2010 Team Explorer  
Microsoft Visual Studio 2010 Team Explorer

Microsoft Visual Web Developer 2010  
Microsoft Visual Web Developer 2010

Crystal Reports Templates for Microsoft Visual Studio 2010  
Crystal Reports Templates for Microsoft Visual Studio 2010

InstallShield Limited Edition  
InstallShield. For more information visit the Flexera Software website at <http://www.FlexeraSoftware.com>. Copyright © 1997–2010 Flexera Software, Inc. and/or InstallShield Co. Inc. All Rights Reserved.

Microsoft Visual Studio 2010 SharePoint Developer Tools   10.0.30319
Microsoft Visual Studio 2010 SharePoint Developer Tools



My Visual Studio 2010 IDE keeps crushing (without exception throw and no windows events logged) whenever try to build the WCF Ria services project for my Silverlight 4 applications. Since there has no exception thrown when IDE crashed, I cannot create the dump file and send you as well. This issue is currently seriously blocking our project development, so very urgent to look for solution. 


So any solution for this issue?


My project sets up a hook WH_GETMSG and use API hook to monitor some API functions exposed by another application. Because the header file of a dll only contains the function name of exposed functions, so I do not know the type of exposed function. I use the default parameter to define the function pointer as:

void (WINAPI * Trampoline_ExposedFunction)(DWORD para1, DWORD para2, DWORD para3, DWORD para4, DWORD para5, DWORD para6) = 0;

In the detour function, I need to use the parameter so I use asm command as following:

    DWORD* pPara1 = NULL;
        push eax
        mov eax, DWORD ptr [para1]
        mov pPara1, eax       
        pop eax


With VS2008, everything works fine. But when I upgrade to VS2010, it crashed the target program. And I point out that the program will be terminated when hitting asm code.

I try to use the old Plaftform Toolset "v90" to compile with VS2010 IDE, but it doesn't help anymore.


Any help?





Unless I disable the text editor database auto update, vs2010 will repeatedly crash. Usually all I have to do is click in a file. If I totally disable the db then it won't even let me add a class. It just cycles on the add class dialog. I've tried deleteing the .sdf file, but this doesn't help.

I don't have any issues editing c# files.

Is there something to look for that could be causing this?

1. Drag a rectangle on to the design surface
2. Drag another rectangle and drop inside the first rectangle
3. Compile

Crashes anytime controls overlap. This is a really big problem, is there a workaround?


I have created a big enum with about 600 entries which compiles fine but as soon as I open the cpp that has this enum included and click in the code VS2010 crashes (when i click on Debug there it gives me: Unhandled exception at 0x11cb49ad in devenv.exe: 0xC0000005: Access violation writing location 0x00000098.)

As the code itself compiles fine and VS2008 doesn't crash with the same code I don't think I've made something wrong code related...

Anyone knows this problem or maybe a solution?


I created an Excel2010 add-in, but it will crash when i add a Ribbon.





I repaired the VS2010, but it crashed still.

My system: Win XP + VS2010 + Office2010



Chinese P-Man

VS2010 VB.Net

When I try to access the Macro IDE or open MyMacros I get the error: Vsaenv: Cannot find one or more components. Please reinstall the application. I have reinstalled (rebuild in place) VS2010 Pro - didn't help.

After the error the IDE goes away for a while and sometimes crashes and sometimes it returns to the code IDE. If I try again as often as not VS crashes hard. On reload it looks like it is going through rebuilding settings.

I've searched around and haven't found a similar problem /solution. Ideas?


VS2010 C# seems to crash from time to time while developing.  When it does, it attempts to connect to MSFT and push Watson dumps up to MSFT.  But, it takes forever (Dr. Watson eats up 40-50% CPU rendering the computer senseless) and makes me wonder if it's really doing anything.  Of course I can't wait 20 to 30 minutes or even longer to get this done, so I kill the transfer and start working again.  What's taking so long on these dumps?

I noticed that it centers around intellisense often.  I'll start a line of code putting in a Type and intellisense kicks in.  The last two dumps occurred when Intellisense is invoked.  Suggestions?

Is there something I'm doing wrong? I have no add-ins installed, a clean install of Win7 64it, but VS2010 crashes frequently. Does anyone have any suggestions??


On some of my bigger Pex-Test Projects, Vs often crashes.
This happens when at least, when I,
1.) Try to Delete the generated Pex Tests
2.) Try to run a Pex Exploration of only one Medoth.

I did send every Windows Error Report, any other info needed ?

I have a VM that I use to do all of my development.  On this VM I'm trying to perform Concurrency Profiling.  However, every time I try to open the report VS crashes.  Any ideas?

<< Previous      Next >>

Microsoft   |   Windows   |   Visual Studio   |   Sharepoint   |   Azure